summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrliang2019-01-10 11:23:06 -0200
committerrliang2019-01-10 11:23:06 -0200
commit3dcc8a498e1a46767d3a1b0b2f056c489c52080f (patch)
treece6c83252da7a150f9e5e67550b13c32a6e892b8
downloadaur-3dcc8a498e1a46767d3a1b0b2f056c489c52080f.tar.gz
Initial commit
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD33
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3629bcdd0d25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = mutter-git
+ pkgdesc = A window manager for GNOME
+ pkgver = 3.31.2+190+gf740e8ed7
+ pkgrel = 1
+ url = https://gitlab.gnome.org/GNOME/mutter
+ arch = x86_64
+ groups = gnome
+ license = GPL
+ makedepends = gtk-doc
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = egl-wayland
+ makedepends = meson
+ depends = dconf
+ depends = gobject-introspection-runtime
+ depends = gsettings-desktop-schemas
+ depends = libcanberra
+ depends = startup-notification
+ depends = zenity
+ depends = libsm
+ depends = gnome-desktop
+ depends = upower
+ depends = libxkbcommon-x11
+ depends = gnome-settings-daemon
+ depends = libgudev
+ depends = libinput
+ depends = pipewire
+ provides = mutter
+ conflicts = mutter
+ source = git+https://gitlab.gnome.org/GNOME/mutter.git
+ sha256sums = SKIP
+
+pkgname = mutter-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9953caf0963c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ricardo Liang (rliang) <ricardoliang@gmail.com>
+
+_pkgname=mutter
+pkgname="$_pkgname"-git
+pkgver=3.31.2+190+gf740e8ed7
+pkgrel=1
+pkgdesc="A window manager for GNOME"
+url="https://gitlab.gnome.org/GNOME/mutter"
+arch=(x86_64)
+license=(GPL)
+provides=(mutter)
+conflicts=(mutter)
+depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas libcanberra
+ startup-notification zenity libsm gnome-desktop upower libxkbcommon-x11
+ gnome-settings-daemon libgudev libinput pipewire)
+makedepends=(gtk-doc gobject-introspection git egl-wayland meson)
+groups=(gnome)
+source=("git+https://gitlab.gnome.org/GNOME/mutter.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ arch-meson $_pkgname build -D gtk_doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}