summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorignapk2022-02-16 00:26:20 +0100
committerignapk2022-02-16 00:27:19 +0100
commit42457373e84eb697f174f9deb5ebd1c0019ace22 (patch)
tree1232a6e2ae73d0e1d89ad7b94267dd2d8ee3d375
parent99e7e644115ea06cf10b1b60ad694e196cb141c5 (diff)
downloadaur-42457373e84eb697f174f9deb5ebd1c0019ace22.tar.gz
add build_drop_catchsegv_meson_dependency.patch to patches
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--build_drop_catchsegv_meson_dependency.patch12
3 files changed, 24 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 868916b800b2..ad68e046831f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mutter-git
pkgdesc = A window manager for GNOME.
- pkgver = 42.alpha+131+g27cbf7b23
+ pkgver = 42.beta
pkgrel = 1
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
@@ -32,6 +32,8 @@ pkgbase = mutter-git
provides = mutter
conflicts = mutter
source = git+https://gitlab.gnome.org/GNOME/mutter.git
+ source = build_drop_catchsegv_meson_dependency.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = mutter-git
diff --git a/PKGBUILD b/PKGBUILD
index 754208a796bf..d14a46a02f72 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=mutter-git
_pkgname=mutter
-pkgver=42.alpha+131+g27cbf7b23
+pkgver=42.beta
pkgrel=1
pkgdesc="A window manager for GNOME."
url="https://gitlab.gnome.org/GNOME/mutter"
@@ -19,8 +19,14 @@ makedepends=(gobject-introspection git egl-wayland meson xorg-server
provides=(mutter)
conflicts=(mutter)
groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/mutter.git")
-sha256sums=('SKIP')
+source=("git+https://gitlab.gnome.org/GNOME/mutter.git"
+ "build_drop_catchsegv_meson_dependency.patch")
+sha256sums=('SKIP' 'SKIP')
+
+prepare() {
+ cd $_pkgname
+ patch --strip=1 --input="$srcdir/build_drop_catchsegv_meson_dependency.patch"
+}
pkgver() {
cd $_pkgname
diff --git a/build_drop_catchsegv_meson_dependency.patch b/build_drop_catchsegv_meson_dependency.patch
new file mode 100644
index 000000000000..dba3163bb980
--- /dev/null
+++ b/build_drop_catchsegv_meson_dependency.patch
@@ -0,0 +1,12 @@
+diff --git a/meson.build b/meson.build
+index 5041755492a662c8f78837ee211f73ffa8e26c11..dc7b16361afdff09abc2da3b218da6e6f7947034 100644
+--- a/meson.build
++++ b/meson.build
+@@ -333,7 +333,6 @@ if have_tests
+ ],
+ exe_wrapper: [
+ default_test_wrappers,
+- find_program('catchsegv'),
+ find_program('xvfb-run'), '-a', '-s', '+iglx -noreset',
+ ],
+ timeout_multiplier: 10,