aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulian Sparber2017-02-18 13:15:17 +0100
committerJulian Sparber2017-02-18 13:15:17 +0100
commit7548c39d0d04d38a4fa2600682832705537ebcf3 (patch)
tree47fdb1d3b23c85ad61a850757ce164335c55a10b
parent1c53b5bacb3baca7af7b1464a79784a8d848a620 (diff)
downloadaur-7548c39d0d04d38a4fa2600682832705537ebcf3.tar.gz
[update] to 3.22.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--startup-notification.patch45
3 files changed, 59 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa905576ddbf..494529a0921d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu Oct 13 10:42:02 UTC 2016
+# Sat Feb 18 12:14:34 UTC 2017
pkgbase = mutter-hide-legacy-decorations
pkgdesc = A window manager for GNOME (with a little hack to hide the window decorations on maximized legacy applications)
- pkgver = 3.22.1
+ pkgver = 3.22.3
pkgrel = 1
url = https://git.gnome.org/browse/mutter
arch = i686
@@ -26,15 +26,17 @@ pkgbase = mutter-hide-legacy-decorations
depends = gnome-settings-daemon
depends = libgudev
depends = libinput
- provides = mutter=3.22.1
+ provides = mutter=3.22.3
conflicts = mutter-wayland
conflicts = mutter
replaces = mutter-wayland
replaces = mutter
options = !emptydirs
- source = git://git.gnome.org/mutter#commit=f63bb024fa72887b845c8cfb6c06d5338f35f4dd
+ source = git://git.gnome.org/mutter#commit=afb4165262ac7b51229663fdf859aee2dcc4b4e8
+ source = startup-notification.patch
source = hideTitlebar.patch
sha256sums = SKIP
+ sha256sums = 5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366
sha256sums = ec1a0f5f98213c340e907761e72fc3e22cb9c8ff503c6c234a4a41aac4ec7ac4
pkgname = mutter-hide-legacy-decorations
diff --git a/PKGBUILD b/PKGBUILD
index 7862c5a00ac2..7256b10f8b2b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mutter-hide-legacy-decorations
_pkgname=mutter
-pkgver=3.22.1
+pkgver=3.22.3
pkgrel=1
pkgdesc="A window manager for GNOME (with a little hack to hide the window decorations on maximized legacy applications)"
url="https://git.gnome.org/browse/mutter"
@@ -21,12 +21,13 @@ provides=("mutter=${pkgver}")
groups=(gnome)
options=(!emptydirs)
-
-_commit=f63bb024fa72887b845c8cfb6c06d5338f35f4dd # tags/3.22.1^0
+_commit=afb4165262ac7b51229663fdf859aee2dcc4b4e8 # tags/3.22.3^0
source=("git://git.gnome.org/mutter#commit=$_commit"
+ "startup-notification.patch"
"hideTitlebar.patch")
sha256sums=('SKIP'
+ '5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366'
'ec1a0f5f98213c340e907761e72fc3e22cb9c8ff503c6c234a4a41aac4ec7ac4')
pkgver() {
@@ -36,6 +37,10 @@ pkgver() {
prepare() {
cd $_pkgname
+
+ # https://bugs.archlinux.org/task/51940
+ patch -Np1 -i ../startup-notification.patch
+
NOCONFIGURE=1 ./autogen.sh
}
diff --git a/startup-notification.patch b/startup-notification.patch
new file mode 100644
index 000000000000..1a4dd0b9705f
--- /dev/null
+++ b/startup-notification.patch
@@ -0,0 +1,45 @@
+From 4ed430b4ef3013c96fa56cdc57b925b42d20ead9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
+Date: Thu, 20 Oct 2016 18:00:04 +0200
+Subject: [PATCH] gtk-shell: Work around non-working startup notifications
+
+GNOME Shell relies on the MetaScreen::startup-sequence-changed signal,
+which is tied to (lib)startup-notification and therefore X11. As a result,
+when we remove the startup sequence of a wayland client, GNOME Shell will
+not be notified about this until startup-notification's timeout is hit.
+As a temporary stop-gap, go through XWayland even for wayland clients,
+so that the signal is emitted when expected.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=768531
+---
+ src/wayland/meta-wayland-gtk-shell.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/src/wayland/meta-wayland-gtk-shell.c b/src/wayland/meta-wayland-gtk-shell.c
+index d6e249f..9d1a19e 100644
+--- a/src/wayland/meta-wayland-gtk-shell.c
++++ b/src/wayland/meta-wayland-gtk-shell.c
+@@ -219,11 +219,21 @@ gtk_shell_set_startup_id (struct wl_client *client,
+ struct wl_resource *resource,
+ const char *startup_id)
+ {
++#if 0
+ MetaDisplay *display;
+
+ display = meta_get_display ();
+ meta_startup_notification_remove_sequence (display->startup_notification,
+ startup_id);
++#else
++ /* HACK: MetaScreen::startup-sequence-changed is currently tied to
++ (lib)startup-notification, which means it only works on X11;
++ so for now, always go through XWayland, even for wayland clients */
++ gdk_x11_display_broadcast_startup_message (gdk_display_get_default (),
++ "remove",
++ "ID", startup_id,
++ NULL);
++#endif
+ }
+
+ static void
+--
+2.9.3