summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorraihan20002023-10-19 13:08:45 +0530
committerraihan20002023-10-19 13:08:45 +0530
commitde05df7f5f49bc32ae3ddd7b12b17080d1ec386d (patch)
tree75867627f99ada4e53d63c24e02ae83f42fce60f
parent4570a5d5b0efca2e0567e97f6f1c88f0f6b7c384 (diff)
downloadaur-de05df7f5f49bc32ae3ddd7b12b17080d1ec386d.tar.gz
don't give credentials to git
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0cc5a1cf484e..b5aa45e1a539 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -58,14 +58,11 @@ sha256sums=(SKIP)
pkgver() {
cd mobile-mutter
- if ! git show-ref --tags | grep -q "refs/tags/45.rc"; then
- git config --global user.email "build@manjaro.org"
- git config --global user.name "Manjaro Build Server"
+ _hash=$(git describe --always --long --abbrev=7 | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g')
+ _target=$(git log --grep="Bump version to 45.rc" --pretty=format:"%h")
+ _count=$(git rev-list "$_target"..HEAD --count)
- git tag -a 45.rc 493e799398991e832f3cec38f376e2ec26fc7bda -m "Bump version to 45.rc"
- fi
-
- git describe --long --abbrev=7 --tags "$_commit" | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ echo "45.rc.r$_count.g$_hash"
}
prepare() {