summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-10-16 20:06:57 +0000
committerDaniel Bermond2020-10-16 20:06:57 +0000
commit65d4786661eb588ae51abfa073da58e857b7db9d (patch)
treecec7c2f1cf7fdd14a94b1c11fc9a8627430e1af7
parent681585106f58d92cd3fc634815588868b20c473b (diff)
downloadaur-65d4786661eb588ae51abfa073da58e857b7db9d.tar.gz
Fix initialization by using git sources. Add pgp verification.
Initialization of muwire is broken[1] when building from the tarball. References ---------- [1] https://github.com/zlatinb/muwire/commit/edede81ffceb4356a81f421e6ecb6bea6c29d92f
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 20cf773db2ba..6cc3f8b75670 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,20 @@
pkgbase = muwire
pkgdesc = An I2P file sharing program
pkgver = 0.7.7
- pkgrel = 1
+ pkgrel = 2
url = https://muwire.com/
arch = any
license = GPL3
+ makedepends = git
makedepends = gradle
depends = sh
depends = java-runtime>=9
depends = hicolor-icon-theme
- source = https://github.com/zlatinb/muwire/archive/muwire-0.7.7.tar.gz
+ source = git+https://github.com/zlatinb/muwire.git#commit=16c755e6c64c744a602c7a4c61850b8065e13779?signed
source = muwire.desktop
source = muwire.sh
- sha256sums = e82cbe59d09b07564539138a174924d9f27886b8165971e135f41d017e0cf9b9
+ validpgpkeys = 471B9FD45517A5ED101FC57DA72832072D525E41
+ sha256sums = SKIP
sha256sums = 7d61c69613029bd2b2e82f227a230104b880635fd8d44a649b2192b03c3cc509
sha256sums = 05df19c773e30627da851e1885f01896d2eab35696a56878c06a9a7ebd945a43
diff --git a/PKGBUILD b/PKGBUILD
index a72b9d51f9e8..ae9ba7adfd10 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,33 @@
pkgname=muwire
pkgver=0.7.7
-pkgrel=1
+pkgrel=2
pkgdesc='An I2P file sharing program'
arch=('any')
url='https://muwire.com/'
license=('GPL3')
depends=('sh' 'java-runtime>=9' 'hicolor-icon-theme')
-makedepends=('gradle')
-source=("https://github.com/zlatinb/muwire/archive/muwire-${pkgver}.tar.gz"
+makedepends=('git' 'gradle')
+_commit=16c755e6c64c744a602c7a4c61850b8065e13779
+source=("git+https://github.com/zlatinb/muwire.git#commit=${_commit}?signed"
'muwire.desktop'
'muwire.sh')
-sha256sums=('e82cbe59d09b07564539138a174924d9f27886b8165971e135f41d017e0cf9b9'
+sha256sums=('SKIP'
'7d61c69613029bd2b2e82f227a230104b880635fd8d44a649b2192b03c3cc509'
'05df19c773e30627da851e1885f01896d2eab35696a56878c06a9a7ebd945a43')
+validpgpkeys=('471B9FD45517A5ED101FC57DA72832072D525E41') # Zlatin Balevsky
build() {
- gradle -p "muwire-muwire-${pkgver}" clean assemble
+ gradle -p muwire clean assemble
}
package() {
- bsdtar -xf "muwire-muwire-${pkgver}/gui/build/distributions/gui-shadow-${pkgver}.tar" \
- -C "muwire-muwire-${pkgver}" --strip-components='2' "*/lib/gui-${pkgver}-all.jar"
+ bsdtar -xf "muwire/gui/build/distributions/gui-shadow-${pkgver%%.r*}.tar" \
+ -C muwire --strip-components='2' "*/lib/gui-${pkgver%%.r*}-all.jar"
install -D -m755 muwire.sh "${pkgdir}/usr/bin/muwire"
install -D -m644 muwire.desktop -t "${pkgdir}/usr/share/applications"
- install -D -m644 "muwire-muwire-${pkgver}/gui-${pkgver}-all.jar" "${pkgdir}/usr/share/java/muwire.jar"
+ install -D -m644 "muwire/gui-${pkgver}-all.jar" "${pkgdir}/usr/share/java/muwire.jar"
local _file
local _res
@@ -34,5 +36,5 @@ package() {
do
_res="$(sed 's/\.png$//;s/^.*x//' <<< "$_file")"
install -D -m644 "$_file" "${pkgdir}/usr/share/icons/hicolor/${_res}x${_res}/apps/${pkgname}.png"
- done < <(find "muwire-muwire-${pkgver}/gui/griffon-app/resources" -maxdepth 1 -type f -name 'MuWire-*x*.png' -print0)
+ done < <(find muwire/gui/griffon-app/resources -maxdepth 1 -type f -name 'MuWire-*x*.png' -print0)
}