summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2016-10-18 01:12:51 +0200
committerbartus2016-10-18 01:12:51 +0200
commit0fe99ab2c005840d716201850448980f707e5be5 (patch)
treebddefe4c530a95db0450f8f6301aa3a20d48c5cb
downloadaur-0fe99ab2c005840d716201850448980f707e5be5.tar.gz
initial commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD95
-rw-r--r--gtest.patch16
3 files changed, 139 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9c046ca107c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = mve-git
+ pkgdesc = Image-based geometry reconstruction pipeline, surface-from-motion, multi-view-stereo, surface-reconstruction, texturing
+ pkgver = r1077.cab91ca
+ pkgrel = 1
+ url = http://www.gcc.tu-darmstadt.de/home/proj/mve/
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = GPL
+ makedepends = git
+ makedepends = go-md2man
+ makedepends = gcc5
+ depends = libjpeg
+ depends = libtiff
+ depends = libpng
+ depends = libgl
+ depends = qt5-base
+ source = mve-git::git+https://github.com/simonfuhrmann/mve.git
+ source = mve-git-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git
+ source = git+https://github.com/nmoehrle/mvs-texturing.git
+ source = gtest.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = 71bd51725466027d43aa3b6ec4468249
+
+pkgname = mve-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d914982b6cfe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,95 @@
+# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
+pkgname=mve-git
+pkgver=r1077.cab91ca
+pkgrel=1
+pkgdesc="Image-based geometry reconstruction pipeline, surface-from-motion, multi-view-stereo, surface-reconstruction, texturing"
+arch=('i686' 'x86_64')
+url="http://www.gcc.tu-darmstadt.de/home/proj/mve/"
+license=('BSD' 'GPL')
+groups=()
+depends=('libjpeg' 'libtiff' 'libpng' 'libgl' 'qt5-base')
+makedepends=('git' 'go-md2man' 'gcc5')
+provides=()
+options=()
+source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
+ "${pkgname}-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git"
+ "git+https://github.com/nmoehrle/mvs-texturing.git"
+ 'gtest.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ '71bd51725466027d43aa3b6ec4468249')
+_binar="apps/sfmrecon/sfmrecon
+apps/meshconvert/meshconvert
+apps/meshalign/meshalign
+apps/fssrecon/fssrecon
+apps/mesh2pset/mesh2pset
+apps/bundle2pset/bundle2pset
+apps/dmrecon/dmrecon
+apps/umve/umve
+apps/meshclean/meshclean
+apps/scene2pset/scene2pset
+apps/makescene/makescene
+apps/sceneupgrade/sceneupgrade"
+
+prepare() {
+ cd ${srcdir}/${pkgname}
+ patch -Np1 -i ../gtest.patch
+}
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd ${srcdir}/${pkgname}
+
+ msg "build cli applications"
+ make
+
+ msg "build qt quit"
+ cd apps/umve
+ qmake
+ make
+
+ msg "build testrecon"
+ warning "* **IMPORTANT**: For research purposes only you can use
+ cmake -DRESEARCH=ON
+ instead. This downloads and links against Olga Veksler et al.'s multi-label
+ graph cut optimization, which tends to find better optima and gives better
+ texturing results. However, it is patented and can only be licensed for
+ non-research purposes by the respective authors. For non-research purposes
+ you have to stick to not using the RESEARCH flag. This will use Loopy Belief
+ Propagation instead of Graph Cut Optimization."
+ cd ${srcdir}/mvs-texturing
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_CXX_COMPILER=/usr/bin/g++-5 -DCMAKE_C_COMPILER=/usr/bin/gcc-5 -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../
+ make
+
+ msg "build man pages form markdown wiki pages"
+ cd ${srcdir}/${pkgname}-wiki
+ go-md2man -in MVE-Users-Guide.md -out umve.1
+ go-md2man -in FSSR-Users-Guide.md -out fssrecon.1
+}
+
+check() {
+ cd ${srcdir}/${pkgname}/tests
+ make
+ ./test
+}
+
+package() {
+ cd ${srcdir}/${pkgname}
+ install -Dm644 LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+ install -Dm755 -t ${pkgdir}/usr/bin ${_binar}
+ install -Dm644 -t ${pkgdir}/usr/share/umve/shaders apps/umve/shaders/*
+ cd ${srcdir}/mvs-texturing/build
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ../LICENSE.txt ${pkgdir}/usr/share/licenses/mvs-texturing/LICENSE.txt
+ cd ${srcdir}/${pkgname}-wiki
+ install -Dm644 -t ${pkgdir}/usr/share/man/man1 umve.1 fssrecon.1
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gtest.patch b/gtest.patch
new file mode 100644
index 000000000000..ef3950eb67b9
--- /dev/null
+++ b/gtest.patch
@@ -0,0 +1,16 @@
+diff --git a/tests/Makefile b/tests/Makefile
+index f179d48..8927a5c 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -7,9 +7,9 @@ SOURCES = $(wildcard math/gtest_*.cc) $(wildcard mve/gtest_*.cc) $(wildcard sfm/
+ INCLUDES = -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
+ CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
+ CXXFLAGS = -std=c++11 -pthread ${CXXWARNINGS} ${INCLUDES}
+-LDLIBS += -lpng -ltiff -ljpeg
++LDLIBS += -lpng -ltiff -ljpeg -lgtest -lgtest_main
+
+-test: ${SOURCES:.cc=.o} libmve_fssr.a libmve_sfm.a libmve.a libmve_util.a gtest_main.a
++test: ${SOURCES:.cc=.o} libmve_fssr.a libmve_sfm.a libmve.a libmve_util.a
+ ${LINK.cc} -o $@ $^ ${LDLIBS}
+
+ clean: