summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-06-04 18:27:27 +0200
committerbartus2017-06-04 18:27:27 +0200
commit717a626e01837e67778b12aa44eb35b10f594453 (patch)
treefa2d7fe6f3673e822ebb050b18dabb9dc967124f
parent5629b6ff188d3c85f040dbdcd253c41556040938 (diff)
downloadaur-717a626e01837e67778b12aa44eb35b10f594453.tar.gz
add required gcc see fags for proper build in chroot env
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 407e7b39f767..1b4235051afe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,13 +16,15 @@ source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
"git+https://github.com/nmoehrle/mvs-texturing.git"
"git+https://github.com/flanggut/smvs.git"
'gtest.patch'
- 'umve.opengl.patch')
+ 'umve.opengl.patch'
+ )
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'7e7d7c62d2a191fd4d27dde052035fcf'
- 'bfd0e38c522498b371de12b7ecad4856')
+ 'bfd0e38c522498b371de12b7ecad4856'
+ )
_binar="apps/sfmrecon/sfmrecon
apps/meshconvert/meshconvert
apps/meshalign/meshalign
@@ -41,6 +43,7 @@ prepare() {
patch -Np1 -i gtest.patch
cd ${pkgname}
patch -Np1 -i ../umve.opengl.patch
+ sed -i '/CXXFLAGS*/s/$/ -msse4.2/' libs/sfm/Makefile
}
pkgver() {
@@ -76,6 +79,7 @@ build() {
msg "build Shading-aware Multi-view Stereo"
cd ${srcdir}/smvs
+ sed -i "s:msse4.1:msse4.2:" lib/Makefile tools/Makefile app/Makefile
sed -i "s:mve:mve-git:" Makefile.inc
make