summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Hambrecht2015-06-29 23:15:49 +0200
committerJan Hambrecht2015-06-29 23:15:49 +0200
commit01a057ae1b3be37c1f3cd9ce74b0c876dc524e9e (patch)
treef3638468611feeab947f3c7534995ee55371e0ec
downloadaur-01a057ae1b3be37c1f3cd9ce74b0c876dc524e9e.tar.gz
Migrate to AUR 4
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD36
-rw-r--r--fix-perl-net-interface-use.patch21
-rw-r--r--mvpboot.service11
-rwxr-xr-xmvptftp6
-rw-r--r--mvptftp.service13
6 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..858158218815
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = mvpboot
+ pkgdesc = Respond to boot request packets from Hauppauge MediaMVP
+ pkgver = 0.01
+ pkgrel = 6
+ url = http://mvpmc.wikispaces.com/mvpboot
+ arch = any
+ license = GPL2
+ depends = perl
+ depends = perl-net-interface
+ depends = perl-io-socket
+ optdepends = atftpd: tftp booting support
+ provides = mvpboot
+ noextract = mvpboot
+ source = http://mvpmc.wikispaces.com/file/view/mvpboot/30989151/mvpboot
+ source = fix-perl-net-interface-use.patch
+ source = mvpboot.service
+ source = mvptftp
+ source = mvptftp.service
+ md5sums = 2661beb243f81645344fe89acb97517d
+ md5sums = 5ab5f9917a65c74a288a5d4bffd68fe4
+ md5sums = cdc0e37925b598221795972f392e1186
+ md5sums = 8eff12f2c09d918a6aad7c45650ceeb5
+ md5sums = 48c70b270bf8b1e8e5d942219b65be23
+
+pkgname = mvpboot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2817062ac62e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Jan Hambrecht <jaham at gmx dot net>
+
+pkgname=mvpboot
+pkgver=0.01
+pkgrel=6
+pkgdesc="Respond to boot request packets from Hauppauge MediaMVP"
+arch=('any')
+url="http://mvpmc.wikispaces.com/mvpboot"
+license=('GPL2')
+depends=('perl' 'perl-net-interface' 'perl-io-socket')
+optdepends=(
+ 'atftpd: tftp booting support'
+)
+provides=('mvpboot')
+options=()
+install=
+source=(http://mvpmc.wikispaces.com/file/view/mvpboot/30989151/mvpboot fix-perl-net-interface-use.patch mvpboot.service mvptftp mvptftp.service)
+noextract=("mvpboot")
+
+md5sums=('2661beb243f81645344fe89acb97517d'
+ '5ab5f9917a65c74a288a5d4bffd68fe4'
+ 'cdc0e37925b598221795972f392e1186'
+ '8eff12f2c09d918a6aad7c45650ceeb5'
+ '48c70b270bf8b1e8e5d942219b65be23')
+
+prepare() {
+ pwd
+ patch --follow-symlinks -p0 < fix-perl-net-interface-use.patch
+}
+
+package() {
+ install -Dm755 ${srcdir}/mvpboot ${pkgdir}/usr/bin/mvpboot
+ install -Dm644 ${srcdir}/mvpboot.service ${pkgdir}/usr/lib/systemd/system/mvpboot.service
+ install -Dm755 ${srcdir}/mvptftp ${pkgdir}/usr/bin/mvptftp
+ install -Dm644 ${srcdir}/mvptftp.service ${pkgdir}/usr/lib/systemd/system/mvptftp.service
+}
diff --git a/fix-perl-net-interface-use.patch b/fix-perl-net-interface-use.patch
new file mode 100644
index 000000000000..a68399c67e97
--- /dev/null
+++ b/fix-perl-net-interface-use.patch
@@ -0,0 +1,21 @@
+--- mvpboot 2013-06-05 23:07:17.285948746 +0200
++++ mvpboot-fixed 2011-10-22 18:25:36.000000000 +0200
+@@ -88,7 +88,8 @@
+ my $if = Net::Interface->new($opts{i}) or die "$!\n";
+ my $ifaddr = scalar($if->address) or die "No IP address found for ".$opts{i}."\n";
+ my $local_addr = net2quad($ifaddr);
+-my $local_hwaddr = unpack('H*', scalar $if->hwaddress);
++my $info = $if->info();
++my $local_hwaddr = unpack('H*', $info->{'mac'});
+
+ daemonise($opts{p});
+
+@@ -97,7 +98,7 @@
+ Proto => 'udp',
+ ) or log_die "Failed to bind socket: $!\n";
+
+-syslog 'info', "MediaMVP UDP listener running on $local_addr:$MVP_PORT(".mac_bin2hex(scalar $if->hwaddress).")";
++syslog 'info', "MediaMVP UDP listener running on $local_addr:$MVP_PORT(".$if->mac_bin2hex($info->{'mac'}).")";
+
+ my $data;
+ while (1) {
diff --git a/mvpboot.service b/mvpboot.service
new file mode 100644
index 000000000000..6bb59b161a52
--- /dev/null
+++ b/mvpboot.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Respond to boot request packets from Hauppauge MediaMVP
+After=network.target
+
+[Service]
+Type=forking
+ExecStart=/usr/bin/mvpboot
+
+[Install]
+WantedBy=multi-user.target
+
diff --git a/mvptftp b/mvptftp
new file mode 100755
index 000000000000..d223e8cbb408
--- /dev/null
+++ b/mvptftp
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+# some services needed for the MediaMVP to boot
+/usr/bin/atftpd --daemon --user nobody --group nobody --port 16869 --retry-timeout 120 --mcast-port 1758 --mcast-addr 192.168.2.0-255 --verbose=7
+/usr/bin/atftpd --daemon --user nobody --group nobody --port 69 --verbose=7
+
diff --git a/mvptftp.service b/mvptftp.service
new file mode 100644
index 000000000000..3a22af5d44af
--- /dev/null
+++ b/mvptftp.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=MediaMVP tftp boot server
+ConditionFileIsExecutable=/usr/bin/mvptftp
+
+[Service]
+Type=oneshot
+ExecStart=/usr/bin/mvptftp
+
+TimeoutSec=0
+RemainAfterExit=yes
+
+[Install]
+WantedBy=multi-user.target