summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2021-07-23 03:39:02 +0100
committerJoaquim Monteiro2021-07-23 03:39:02 +0100
commit13669761de41cd1a106036a664f7ce977027bd26 (patch)
tree31f2c8852ef25f98bbf5a387dfe34644744881c3
downloadaur-13669761de41cd1a106036a664f7ce977027bd26.tar.gz
Initial commit
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2a566368e4f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = mvt
+ pkgdesc = Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices
+ pkgver = 1.0.11
+ pkgrel = 1
+ url = https://github.com/mvt-project/mvt
+ arch = any
+ license = custom
+ makedepends = python-pip
+ makedepends = python-setuptools
+ depends = libusb
+ depends = python-adb_shell
+ depends = python-biplist
+ depends = python-click
+ depends = python-iosbackup
+ depends = python-libusb1
+ depends = python-rich
+ depends = python-tld
+ depends = python-tqdm
+ depends = python-requests
+ depends = python-simplejson
+ source = mvt-1.0.11.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.0.11.tar.gz
+ sha512sums = d711256d3e7d8b863d05fbce07f2c35f9e3e75d63287ce84534de52e13eac1a453d562c5647e8eccde8145eb7546a471e855f2ff93ce60d7e5ed97b65977ff97
+
+pkgname = mvt
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ad13f48e845d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.pkg*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c47631188533
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Joaquim Monteiro <joaquim.monteiro@protonmail.com>
+
+pkgname=mvt
+pkgver=1.0.11
+pkgrel=1
+pkgdesc="Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices"
+arch=(any)
+url="https://github.com/mvt-project/mvt"
+license=('custom')
+depends=('libusb' 'python-adb_shell' 'python-biplist' 'python-click' 'python-iosbackup' 'python-libusb1' 'python-rich' 'python-tld' 'python-tqdm' 'python-requests' 'python-simplejson')
+makedepends=('python-pip' 'python-setuptools')
+source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('d711256d3e7d8b863d05fbce07f2c35f9e3e75d63287ce84534de52e13eac1a453d562c5647e8eccde8145eb7546a471e855f2ff93ce60d7e5ed97b65977ff97')
+
+package() {
+ cd "mvt-${pkgver}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="$pkgdir" --optimize=1
+}