summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2021-10-18 15:48:32 +0100
committerJoaquim Monteiro2021-10-18 15:48:32 +0100
commit6b399d90ec861fdb1c833f4d2c1645fd2a58fa87 (patch)
tree62a623eebc4ca5b9dbc1c840c58cc48d7da7fe8d
parent969df95eecb0407144d09456017e8d376197f3d4 (diff)
downloadaur-6b399d90ec861fdb1c833f4d2c1645fd2a58fa87.tar.gz
v1.2.12
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--deps.patch16
3 files changed, 18 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc7814175551..c6e1188993f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mvt
pkgdesc = Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices
- pkgver = 1.2.11
+ pkgver = 1.2.12
pkgrel = 1
url = https://github.com/mvt-project/mvt
arch = any
@@ -18,9 +18,9 @@ pkgbase = mvt
depends = python-tqdm
depends = python-requests
depends = python-simplejson
- source = mvt-1.2.11.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.2.11.tar.gz
+ source = mvt-1.2.12.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.2.12.tar.gz
source = deps.patch
- sha512sums = f7cd44a3a041f0206828c48ad757019c2da4dda31402d3a3d356b23332c60db999397e8c336d5ba74b41e2e02204322883af7abb9ce89d33b1b7a1ef495eba4e
- sha512sums = 09a897e1eeb66d11a2bc5fe5dc0b9f2cd3e9c6781f4fddd91e20513fb930a7ca0e326ad86d5db03d44fa0f945fedbda33d856789678a8ff02f43f8c2c9029e12
+ sha512sums = ce412a200adedd76d413956138fd452c081347c53db7e06ab166df6fe74bc18ea3d96a9798a1f5078ae3f614aeefd137a30d30908e92396cc7c145beba1aff68
+ sha512sums = 6a4d2d5a92f36dc1b53b5256fbde80808d7046f036c3956133bc58bd62ff5b1fbcbc262cf6fefaebb3a3699942d735b188ae57472f8dd4ac89b11755a21c10c7
pkgname = mvt
diff --git a/PKGBUILD b/PKGBUILD
index b5a7ce2ce649..c5a76ea92b81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joaquim Monteiro <joaquim.monteiro@protonmail.com>
pkgname=mvt
-pkgver=1.2.11
+pkgver=1.2.12
pkgrel=1
pkgdesc="Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices"
arch=(any)
@@ -11,8 +11,8 @@ depends=('libusb' 'python' 'python-adb_shell' 'python-click' 'python-iosbackup'
makedepends=('python-setuptools')
source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz"
deps.patch)
-sha512sums=('f7cd44a3a041f0206828c48ad757019c2da4dda31402d3a3d356b23332c60db999397e8c336d5ba74b41e2e02204322883af7abb9ce89d33b1b7a1ef495eba4e'
- '09a897e1eeb66d11a2bc5fe5dc0b9f2cd3e9c6781f4fddd91e20513fb930a7ca0e326ad86d5db03d44fa0f945fedbda33d856789678a8ff02f43f8c2c9029e12')
+sha512sums=('ce412a200adedd76d413956138fd452c081347c53db7e06ab166df6fe74bc18ea3d96a9798a1f5078ae3f614aeefd137a30d30908e92396cc7c145beba1aff68'
+ '6a4d2d5a92f36dc1b53b5256fbde80808d7046f036c3956133bc58bd62ff5b1fbcbc262cf6fefaebb3a3699942d735b188ae57472f8dd4ac89b11755a21c10c7')
prepare() {
cd "mvt-${pkgver}"
diff --git a/deps.patch b/deps.patch
index bba70edb4269..74a11e99edd8 100644
--- a/deps.patch
+++ b/deps.patch
@@ -1,13 +1,19 @@
diff --git a/setup.py b/setup.py
-index dd929fe..7cb1e1a 100755
+index e6f0dc3..3220eb2 100755
--- a/setup.py
+++ b/setup.py
-@@ -22,7 +22,7 @@ requires = (
- "tqdm>=4.61.2",
+@@ -22,12 +22,12 @@ requires = (
+ "tqdm>=4.62.3",
"requests>=2.26.0",
- "simplejson>=3.17.3",
+ "simplejson>=3.17.5",
- "packaging>=21.0",
+ "packaging>=20.9",
# iOS dependencies:
- "iOSbackup>=0.9.912",
+ "iOSbackup>=0.9.921",
# Android dependencies:
+ "adb-shell>=0.4.1",
+- "libusb1>=2.0.1",
++ "libusb1>=1.9.3",
+ )
+
+ def get_package_data(package):