summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2021-12-21 14:38:58 +0000
committerJoaquim Monteiro2021-12-21 14:38:58 +0000
commit73d4c9b7f2f712832c30227d46d6b5560bf3e8c8 (patch)
tree87f02cd7f991ba0cba59556d19afdda80fd8a4e9
parent7d6f080a8db108bd54397c770d6fa6960f7127d6 (diff)
downloadaur-73d4c9b7f2f712832c30227d46d6b5560bf3e8c8.tar.gz
v1.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--deps.patch10
3 files changed, 9 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d892e201d63..6bbffaa2993c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mvt
pkgdesc = Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices
- pkgver = 1.2.14
+ pkgver = 1.4.0
pkgrel = 1
url = https://github.com/mvt-project/mvt
arch = any
@@ -18,9 +18,9 @@ pkgbase = mvt
depends = python-tqdm
depends = python-requests
depends = python-simplejson
- source = mvt-1.2.14.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.2.14.tar.gz
+ source = mvt-1.4.0.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.4.0.tar.gz
source = deps.patch
- sha512sums = 4e5be5249be499391211d13c3fc546204371dda5f2cba62c42cd0499147f8532fe992abb5a0051a1832849552f530b82cea2a0ea22a395ac8324886b706cd172
- sha512sums = 47ca5fa43e5a48703c617a1a707434638788d9fe21605b892872b1f03c25c18b8b0868f8195ce6d553e3796d26cdd692cb5102a09fe361f2a2c826f946ff4070
+ sha512sums = a878536b70543dd29db5ca8ca50eecd17b58b29d2e055a6870f46a788c8db35d5168790f6dcc7d7a1893b6c88c6d9f7b347ca88edb7e339a3823e7ed50cfe5ac
+ sha512sums = a58446d6d969e1f64c972a3c4bef50cef22be2f7d5a1b3032ec8beb1dd46e24836a337ceb895caaa3ceac8f7fd7cb118538833abb47fba98427a904eb8407b49
pkgname = mvt
diff --git a/PKGBUILD b/PKGBUILD
index b2125c74a96d..1aabc81a7607 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Joaquim Monteiro <joaquim.monteiro@protonmail.com>
pkgname=mvt
-pkgver=1.2.14
+pkgver=1.4.0
pkgrel=1
pkgdesc="Collection of utilities to simplify and automate the process of gathering forensic traces helpful to identify a potential compromise of Android and iOS devices"
arch=(any)
@@ -11,8 +11,8 @@ depends=('libusb' 'python' 'python-adb_shell' 'python-click' 'python-iosbackup'
makedepends=('python-setuptools')
source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz"
deps.patch)
-sha512sums=('4e5be5249be499391211d13c3fc546204371dda5f2cba62c42cd0499147f8532fe992abb5a0051a1832849552f530b82cea2a0ea22a395ac8324886b706cd172'
- '47ca5fa43e5a48703c617a1a707434638788d9fe21605b892872b1f03c25c18b8b0868f8195ce6d553e3796d26cdd692cb5102a09fe361f2a2c826f946ff4070')
+sha512sums=('a878536b70543dd29db5ca8ca50eecd17b58b29d2e055a6870f46a788c8db35d5168790f6dcc7d7a1893b6c88c6d9f7b347ca88edb7e339a3823e7ed50cfe5ac'
+ 'a58446d6d969e1f64c972a3c4bef50cef22be2f7d5a1b3032ec8beb1dd46e24836a337ceb895caaa3ceac8f7fd7cb118538833abb47fba98427a904eb8407b49')
prepare() {
cd "mvt-${pkgver}"
diff --git a/deps.patch b/deps.patch
index 8dac86661778..55735f508fa7 100644
--- a/deps.patch
+++ b/deps.patch
@@ -1,8 +1,8 @@
diff --git a/setup.py b/setup.py
-index dc107b6..295ceeb 100755
+index 6af594e..a3e41ac 100755
--- a/setup.py
+++ b/setup.py
-@@ -22,12 +22,12 @@ requires = (
+@@ -22,7 +22,7 @@ requires = (
"tqdm>=4.62.3",
"requests>=2.26.0",
"simplejson>=3.17.5",
@@ -11,9 +11,3 @@ index dc107b6..295ceeb 100755
# iOS dependencies:
"iOSbackup>=0.9.921",
# Android dependencies:
- "adb-shell>=0.4.2",
-- "libusb1>=2.0.1",
-+ "libusb1>=1.9.3",
- )
-
- def get_package_data(package):