summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoaquim Monteiro2021-10-14 19:40:17 +0100
committerJoaquim Monteiro2021-10-14 19:40:17 +0100
commit969df95eecb0407144d09456017e8d376197f3d4 (patch)
treed91c060295cf57a5a1c0929ca2b40fa985a30f89
parent340370b9f351d00a0132fc7900abd51bb798279b (diff)
downloadaur-969df95eecb0407144d09456017e8d376197f3d4.tar.gz
Patch setup.py to use the python-packaging version in the repos and switch to python-tld-git as python-tld is out of date
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--deps.patch13
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0255e9c767f1..bc7814175551 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,11 +14,13 @@ pkgbase = mvt
depends = python-libusb1
depends = python-packaging
depends = python-rich
- depends = python-tld
+ depends = python-tld-git>=0.12.6
depends = python-tqdm
depends = python-requests
depends = python-simplejson
source = mvt-1.2.11.tar.gz::https://github.com/mvt-project/mvt/archive/refs/tags/v1.2.11.tar.gz
+ source = deps.patch
sha512sums = f7cd44a3a041f0206828c48ad757019c2da4dda31402d3a3d356b23332c60db999397e8c336d5ba74b41e2e02204322883af7abb9ce89d33b1b7a1ef495eba4e
+ sha512sums = 09a897e1eeb66d11a2bc5fe5dc0b9f2cd3e9c6781f4fddd91e20513fb930a7ca0e326ad86d5db03d44fa0f945fedbda33d856789678a8ff02f43f8c2c9029e12
pkgname = mvt
diff --git a/PKGBUILD b/PKGBUILD
index 8666b02961c6..b5a7ce2ce649 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,17 @@ pkgdesc="Collection of utilities to simplify and automate the process of gatheri
arch=(any)
url="https://github.com/mvt-project/mvt"
license=('custom')
-depends=('libusb' 'python' 'python-adb_shell' 'python-click' 'python-iosbackup' 'python-libusb1' 'python-packaging' 'python-rich' 'python-tld' 'python-tqdm' 'python-requests' 'python-simplejson')
+depends=('libusb' 'python' 'python-adb_shell' 'python-click' 'python-iosbackup' 'python-libusb1' 'python-packaging' 'python-rich' 'python-tld-git>=0.12.6' 'python-tqdm' 'python-requests' 'python-simplejson')
makedepends=('python-setuptools')
-source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz")
-sha512sums=('f7cd44a3a041f0206828c48ad757019c2da4dda31402d3a3d356b23332c60db999397e8c336d5ba74b41e2e02204322883af7abb9ce89d33b1b7a1ef495eba4e')
+source=("mvt-${pkgver}.tar.gz"::"https://github.com/mvt-project/mvt/archive/refs/tags/v${pkgver}.tar.gz"
+ deps.patch)
+sha512sums=('f7cd44a3a041f0206828c48ad757019c2da4dda31402d3a3d356b23332c60db999397e8c336d5ba74b41e2e02204322883af7abb9ce89d33b1b7a1ef495eba4e'
+ '09a897e1eeb66d11a2bc5fe5dc0b9f2cd3e9c6781f4fddd91e20513fb930a7ca0e326ad86d5db03d44fa0f945fedbda33d856789678a8ff02f43f8c2c9029e12')
+
+prepare() {
+ cd "mvt-${pkgver}"
+ patch -p1 -i "$srcdir/deps.patch"
+}
build() {
cd "mvt-${pkgver}"
diff --git a/deps.patch b/deps.patch
new file mode 100644
index 000000000000..bba70edb4269
--- /dev/null
+++ b/deps.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index dd929fe..7cb1e1a 100755
+--- a/setup.py
++++ b/setup.py
+@@ -22,7 +22,7 @@ requires = (
+ "tqdm>=4.61.2",
+ "requests>=2.26.0",
+ "simplejson>=3.17.3",
+- "packaging>=21.0",
++ "packaging>=20.9",
+ # iOS dependencies:
+ "iOSbackup>=0.9.912",
+ # Android dependencies: