summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2018-01-21 13:12:56 -0800
committerAaron DeVore2018-01-21 13:12:56 -0800
commit9938d59cc3bda4bb32aa2980d9ab91b1546d7a6d (patch)
tree76707e9e11774a9b06d86bab24f73d65ad5eb64d
parent19bdbce003be40a48cbe50047ff7b12ff1912a49 (diff)
downloadaur-mwlib.tar.gz
Version bump to 0.15.19
Also fix python2-twisted dependency
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ffe4fd3bf17..cbf27df2b8ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Sun Jan 21 21:12:49 UTC 2018
pkgbase = mwlib
pkgdesc = Converts MediaWiki articles to pdf, odf, and docbook
- pkgver = 0.15.14
- pkgrel = 2
+ pkgver = 0.15.19
+ pkgrel = 1
url = http://code.pediapress.com/wiki/wiki
changelog = Changelog
arch = i686
@@ -15,7 +17,7 @@ pkgbase = mwlib
depends = python2-odfpy
depends = python2-flup
depends = python2-pyparsing>=1.4.11
- depends = twisted
+ depends = python2-twisted
depends = python2-dateutil>=1.4.1
depends = python2-pypdf>=1.12
depends = python2-webob
@@ -32,9 +34,9 @@ pkgbase = mwlib
optdepends = texvc
optdepends = imagemagick
optdepends = blahtex
- source = http://pypi.python.org/packages/source/m/mwlib/mwlib-0.15.14.zip
+ source = https://files.pythonhosted.org/packages/source/m/mwlib/mwlib-0.15.19.zip
source = license.txt
- md5sums = 137a565db5327f85d2c399dbdec5c92b
+ md5sums = c07887b34b35fbaa962ba19bfb01f327
md5sums = 62eb6f0bfb7c407593db61962e221844
pkgname = mwlib
diff --git a/PKGBUILD b/PKGBUILD
index 46626a7e545a..7dc7e810b8a5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,26 @@
# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
# Contributor: Erol V. Aktay <e.aktay@gmail.com>
pkgname='mwlib'
-pkgver='0.15.14'
-pkgrel='2'
+pkgver='0.15.19'
+pkgrel='1'
pkgdesc="Converts MediaWiki articles to pdf, odf, and docbook"
arch=('i686' 'x86_64')
url="http://code.pediapress.com/wiki/wiki"
license=("BSD")
depends=('python2' 'perl' 'python-imaging' 'python2-odfpy' 'python2-flup'
- 'python2-pyparsing>=1.4.11' 'twisted' 'python2-dateutil>=1.4.1' 'python2-pypdf>=1.12' 'python2-webob'
- 'python2-timelib' 'python2-lockfile' 'python2-gevent' 'python2-bottle' 'python2-qserve'
- 'python2-lxml' 'python2-sqlite3dbm' 'python2-roman' 'python2-apipkg' 'python2-py')
+ 'python2-pyparsing>=1.4.11' 'python2-twisted' 'python2-dateutil>=1.4.1' 'python2-pypdf>=1.12'
+ 'python2-webob' 'python2-timelib' 'python2-lockfile' 'python2-gevent' 'python2-bottle'
+ 'python2-qserve' 'python2-lxml' 'python2-sqlite3dbm' 'python2-roman'
+ 'python2-apipkg' 'python2-py')
optdepends=('texvc'
'imagemagick'
'blahtex'
)
makedepends=('re2c' 'python2-setuptools')
changelog=Changelog
-source=("http://pypi.python.org/packages/source/m/$pkgname/$pkgname-$pkgver.zip"
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.zip"
license.txt)
-md5sums=('137a565db5327f85d2c399dbdec5c92b'
+md5sums=('c07887b34b35fbaa962ba19bfb01f327'
'62eb6f0bfb7c407593db61962e221844')
prepare() {