summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:13:54 -0700
committerAaron DeVore2015-07-08 11:13:54 -0700
commit19bdbce003be40a48cbe50047ff7b12ff1912a49 (patch)
treeb9f34e5ccb42222949743590c41eb7b2791b2f7b
downloadaur-19bdbce003be40a48cbe50047ff7b12ff1912a49.tar.gz
Initial import
-rw-r--r--.AURINFO39
-rw-r--r--.SRCINFO41
-rw-r--r--Changelog11
-rw-r--r--PKGBUILD50
-rw-r--r--license.txt33
5 files changed, 174 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..086bf12aaf1c
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,39 @@
+pkgbase = mwlib
+ pkgdesc = Converts MediaWiki articles to pdf, odf, and docbook
+ pkgver = 0.15.14
+ pkgrel = 2
+ url = http://code.pediapress.com/wiki/wiki
+ changelog = Changelog
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = re2c
+ makedepends = python2-setuptools
+ depends = python2
+ depends = perl
+ depends = python-imaging
+ depends = python2-odfpy
+ depends = python2-flup
+ depends = python2-pyparsing>=1.4.11
+ depends = twisted
+ depends = python2-dateutil>=1.4.1
+ depends = python2-pypdf>=1.12
+ depends = python2-webob
+ depends = python2-timelib
+ depends = python2-lockfile
+ depends = python2-gevent
+ depends = python2-bottle
+ depends = python2-qserve
+ depends = python2-lxml
+ depends = python2-sqlite3dbm
+ depends = python2-roman
+ depends = python2-apipkg
+ depends = python2-py
+ optdepends = texvc
+ optdepends = imagemagick
+ optdepends = blahtex
+ source = http://pypi.python.org/packages/source/m/mwlib/mwlib-0.15.14.zip
+ source = license.txt
+
+pkgname = mwlib
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ffe4fd3bf17
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,41 @@
+pkgbase = mwlib
+ pkgdesc = Converts MediaWiki articles to pdf, odf, and docbook
+ pkgver = 0.15.14
+ pkgrel = 2
+ url = http://code.pediapress.com/wiki/wiki
+ changelog = Changelog
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = re2c
+ makedepends = python2-setuptools
+ depends = python2
+ depends = perl
+ depends = python-imaging
+ depends = python2-odfpy
+ depends = python2-flup
+ depends = python2-pyparsing>=1.4.11
+ depends = twisted
+ depends = python2-dateutil>=1.4.1
+ depends = python2-pypdf>=1.12
+ depends = python2-webob
+ depends = python2-timelib
+ depends = python2-lockfile
+ depends = python2-gevent
+ depends = python2-bottle
+ depends = python2-qserve
+ depends = python2-lxml
+ depends = python2-sqlite3dbm
+ depends = python2-roman
+ depends = python2-apipkg
+ depends = python2-py
+ optdepends = texvc
+ optdepends = imagemagick
+ optdepends = blahtex
+ source = http://pypi.python.org/packages/source/m/mwlib/mwlib-0.15.14.zip
+ source = license.txt
+ md5sums = 137a565db5327f85d2c399dbdec5c92b
+ md5sums = 62eb6f0bfb7c407593db61962e221844
+
+pkgname = mwlib
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..38379d180b9e
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,11 @@
+2013-10-23 Aaron DeVore <aaron.devore@gmail.com> (0.15.11)
+- Version bump to 0.15.11
+- Switch python2-distribute -> python2-setuptools
+2013-04-19 Aaron DeVore <aaron.devore@gmail.com> (0.14.1-2)
+- Split build() and package() properly
+2012-12-22 Aaron DeVore <aaron.devore@gmail.com> (0.14.1-1)
+- Version bump to 0.14.1
+- Add license.txt to source array
+- Fix simplejson being downloaded.
+- Remove check(). It wasn't working correctly.
+- Switch python2-lxml to be mandantory, not optional
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..46626a7e545a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Erol V. Aktay <e.aktay@gmail.com>
+pkgname='mwlib'
+pkgver='0.15.14'
+pkgrel='2'
+pkgdesc="Converts MediaWiki articles to pdf, odf, and docbook"
+arch=('i686' 'x86_64')
+url="http://code.pediapress.com/wiki/wiki"
+license=("BSD")
+depends=('python2' 'perl' 'python-imaging' 'python2-odfpy' 'python2-flup'
+ 'python2-pyparsing>=1.4.11' 'twisted' 'python2-dateutil>=1.4.1' 'python2-pypdf>=1.12' 'python2-webob'
+ 'python2-timelib' 'python2-lockfile' 'python2-gevent' 'python2-bottle' 'python2-qserve'
+ 'python2-lxml' 'python2-sqlite3dbm' 'python2-roman' 'python2-apipkg' 'python2-py')
+optdepends=('texvc'
+ 'imagemagick'
+ 'blahtex'
+)
+makedepends=('re2c' 'python2-setuptools')
+changelog=Changelog
+source=("http://pypi.python.org/packages/source/m/$pkgname/$pkgname-$pkgver.zip"
+ license.txt)
+md5sums=('137a565db5327f85d2c399dbdec5c92b'
+ '62eb6f0bfb7c407593db61962e221844')
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # Remove simplejson from the setup.py dependency list. If it is not
+ # removed, simplejson will be automatically downloaded from PyPi.
+ sed -i -e 's/"simplejson>=.*",//' \
+ -e 's/pyparsing>=1.4.11,<1.6/pyparsing>=1.4/' \
+ setup.py
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 "$srcdir/license.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+ # docs
+ mkdir -p "$pkgdir/usr/share/docs/"
+ cp -a "docs" "$pkgdir/usr/share/docs/$pkgname"
+ chmod -R 755 "$pkgdir/usr/share/docs/$pkgname"
+}
+
+
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..69a711f7b33e
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,33 @@
+License
+======================================================================
+Copyright (c) 2007-2009 PediaPress GmbH
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+* Neither the name of PediaPress GmbH nor the names of its
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. \ No newline at end of file