summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:14:57 -0700
committerAaron DeVore2015-07-08 11:14:57 -0700
commit95d16fe6ae5cae4ec9af931e9af4ba80a5094359 (patch)
tree151a3101a973676780f7f9adc034e768e9c7a5d2
downloadaur-95d16fe6ae5cae4ec9af931e9af4ba80a5094359.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD29
-rw-r--r--license.txt32
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..68ac9b6310a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = mwlib.rl
+ pkgdesc = Converts MediaWiki articles to pdf, odf, and docbook
+ pkgver = 0.14.3
+ pkgrel = 1
+ url = http://code.pediapress.com/wiki/wiki
+ arch = any
+ license = BSD
+ makedepends = mercurial
+ makedepends = python2-distribute
+ makedepends = python2-docutils
+ depends = python2
+ depends = mwlib.ext
+ depends = texvc
+ depends = python2-pygments
+ depends = fribidi
+ depends = ploticus
+ depends = imagemagick
+ depends = ghostscript
+ depends = ocaml
+ depends = mwlib
+ source = http://pypi.python.org/packages/source/m/mwlib.rl/mwlib.rl-0.14.3.zip
+ source = license.txt
+ md5sums = 26954d7d58ed2f1c00bc9c4c9ee2630b
+ md5sums = 472b2de7c34ecbd590240179882e36f8
+
+pkgname = mwlib.rl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad290c206137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+pkgname=mwlib.rl
+pkgver=0.14.3
+pkgrel=1
+pkgdesc="Converts MediaWiki articles to pdf, odf, and docbook"
+arch=('any')
+url="http://code.pediapress.com/wiki/wiki"
+license=("BSD")
+depends=('python2' 'mwlib.ext' 'texvc' 'python2-pygments' 'fribidi' 'ploticus'
+'imagemagick' 'ghostscript' 'ocaml' 'mwlib')
+makedepends=('mercurial' 'python2-distribute' 'python2-docutils')
+source=("http://pypi.python.org/packages/source/m/$pkgname/$pkgname-$pkgver.zip"
+ 'license.txt')
+md5sums=('26954d7d58ed2f1c00bc9c4c9ee2630b'
+ '472b2de7c34ecbd590240179882e36f8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
+ install -D -m644 "$srcdir/license.txt" \
+ "$pkgdir/usr/share/licenses/$pkgname/license.txt"
+}
+
diff --git a/license.txt b/license.txt
new file mode 100644
index 000000000000..dc58d0c17f14
--- /dev/null
+++ b/license.txt
@@ -0,0 +1,32 @@
+Copyright (c) 2007, 2008 PediaPress GmbH
+
+All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+* Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+
+* Redistributions in binary form must reproduce the above
+ copyright notice, this list of conditions and the following
+ disclaimer in the documentation and/or other materials provided
+ with the distribution.
+
+* Neither the name of PediaPress GmbH nor the names of its
+ contributors may be used to endorse or promote products derived
+ from this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+