summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2020-01-22 05:07:16 +0100
committerSeverin Glöckner2020-01-22 05:07:16 +0100
commit847182e6a343e073599889cea26c71e99b4c4c85 (patch)
tree30b491fa8fa5c2811372321abac785f5bd821e9e
downloadaur-847182e6a343e073599889cea26c71e99b4c4c85.tar.gz
inital commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD52
-rw-r--r--bash-config.install34
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..749d3c586878
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mx-bash-config-git
+ pkgdesc = GUI tool written in Qt to modify the bashrc
+ pkgver = 19.10.09_110
+ pkgrel = 1
+ url = https://mxlinux.org/wiki/help-files/help-bash-config
+ install = bash-config.install
+ arch = x86_64
+ license = GPL3
+ depends = qt5-base
+ source = git+https://github.com/TheNiteCoder/mx-bashrc-config
+ source = https://raw.githubusercontent.com/MX-Linux/mx-goodies/master/bin/fancy-prompts.bash
+ md5sums = SKIP
+ md5sums = 90de09da55a2ede5f18ab06678a4c76c
+
+pkgname = mx-bash-config-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..926d13f96097
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+
+pkgname=mx-bash-config-git
+pkgver=19.10.09_110
+pkgrel=1
+pkgdesc="GUI tool written in Qt to modify the bashrc "
+arch=('x86_64')
+url="https://mxlinux.org/wiki/help-files/help-bash-config"
+license=('GPL3')
+depends=('qt5-base')
+install=bash-config.install
+source=("git+https://github.com/TheNiteCoder/mx-bashrc-config"
+ "https://raw.githubusercontent.com/MX-Linux/mx-goodies/master/bin/fancy-prompts.bash")
+md5sums=('SKIP'
+ '90de09da55a2ede5f18ab06678a4c76c')
+
+pkgver() {
+ cd "$srcdir"/mx-bashrc-config/application/debian
+
+ # official number from changelog + number of commits as suffix
+ last_release=$(head -n 1 changelog | cut -f 2 -d "(" | cut -f 1 -d ")" )
+ echo -n "${last_release}_" && git rev-list master --count
+}
+
+prepare() {
+ cd "$srcdir"/mx-bashrc-config/application
+
+ # change file location
+ sed -i 's;/usr/local/bin/fancy-prompts.bash;/usr/share/bash-config/fancy-prompts.bash;' *.*
+
+ qmake -config release QMAKE_CXXFLAGS_RELEASE+="${CXXFLAGS} ${CPPFLAGS}"
+}
+
+build() {
+ cd "$srcdir"/mx-bashrc-config/application
+
+ make
+}
+
+package() {
+ # qmake install is not used, copying files mnaually
+
+ cd "$srcdir"/mx-bashrc-config/application
+ # rm translations/*.qm
+
+ install -Dm755 bash-config -t "$pkgdir"/usr/bin/
+ install -Dm644 bashrc-config.desktop -t "$pkgdir"/usr/share/applications/
+ mkdir -p "$pkgdir"/usr/share/doc/bash-config/help
+ cp -r help/* "$pkgdir"/usr/share/doc/bash-config/help
+
+ install -Dm644 "$srcdir"/fancy-prompts.bash -t "$pkgdir"/usr/share/bash-config/
+}
diff --git a/bash-config.install b/bash-config.install
new file mode 100644
index 000000000000..bfbe7a458d65
--- /dev/null
+++ b/bash-config.install
@@ -0,0 +1,34 @@
+post_install() {
+cat << EOF
+
+
+==> Make a backup of ~/.bash_aliases before running this executable!
+==> IT WILL OVERWRITE IT!
+
+==> The programm also adds a new line to your ~/.bashrc
+==> source ~/.config/bash-config/bashrc.bash
+
+
+==> And let me repeat:
+==> Make a backup of ~/.bash_aliases before running this executable!
+==> IT WILL OVERWRITE IT!
+
+
+EOF
+}
+
+post_remove() {
+cat << EOF
+
+
+==> To clean up:
+==> All alias changes have been made in ~/.bash_aliases
+==> Prompt changes are in ~/.config/bash-config
+
+==> This file is included at the end of ~/.bashrc
+==> If you choose the fancy prompt, you will miss now the fancy-prompts.bash
+==> file and must edit one of the above mentiond files.
+
+
+EOF
+}