summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSeverin Glöckner2021-01-28 01:24:04 +0100
committerSeverin Glöckner2021-01-28 01:24:04 +0100
commit878768ba425d967e24f27e378df1f33b1f8d3930 (patch)
tree5c94015ed8a5bceaaf950abbf9e0df0df6d34cfb
parente76f33da937d0d538f1f99cce7ebb99244e188f6 (diff)
downloadaur-878768ba425d967e24f27e378df1f33b1f8d3930.tar.gz
use correct Linker Flags
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD21
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 749d3c586878..bf420a8e9b3f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mx-bash-config-git
pkgdesc = GUI tool written in Qt to modify the bashrc
- pkgver = 19.10.09_110
+ pkgver = 19.10.09_140
pkgrel = 1
url = https://mxlinux.org/wiki/help-files/help-bash-config
install = bash-config.install
arch = x86_64
license = GPL3
+ makedepends = git
depends = qt5-base
source = git+https://github.com/TheNiteCoder/mx-bashrc-config
source = https://raw.githubusercontent.com/MX-Linux/mx-goodies/master/bin/fancy-prompts.bash
diff --git a/PKGBUILD b/PKGBUILD
index 926d13f96097..229cba5f9b5b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,14 @@
-# Maintainer Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
+# Maintainer: Severin Glöckner <severin.gloeckner@stud.htwk-leipzig.de>
pkgname=mx-bash-config-git
-pkgver=19.10.09_110
+pkgver=19.10.09_140
pkgrel=1
-pkgdesc="GUI tool written in Qt to modify the bashrc "
+pkgdesc="GUI tool written in Qt to modify the bashrc"
arch=('x86_64')
url="https://mxlinux.org/wiki/help-files/help-bash-config"
license=('GPL3')
depends=('qt5-base')
+makedepends=('git')
install=bash-config.install
source=("git+https://github.com/TheNiteCoder/mx-bashrc-config"
"https://raw.githubusercontent.com/MX-Linux/mx-goodies/master/bin/fancy-prompts.bash")
@@ -28,7 +29,8 @@ prepare() {
# change file location
sed -i 's;/usr/local/bin/fancy-prompts.bash;/usr/share/bash-config/fancy-prompts.bash;' *.*
- qmake -config release QMAKE_CXXFLAGS_RELEASE+="${CXXFLAGS} ${CPPFLAGS}"
+ qmake -config release QMAKE_CXXFLAGS_RELEASE+="${CXXFLAGS} ${CPPFLAGS}" \
+ QMAKE_LFLAGS_RELEASE+="${LDFLAGS}"
}
build() {
@@ -38,15 +40,12 @@ build() {
}
package() {
- # qmake install is not used, copying files mnaually
-
cd "$srcdir"/mx-bashrc-config/application
- # rm translations/*.qm
- install -Dm755 bash-config -t "$pkgdir"/usr/bin/
- install -Dm644 bashrc-config.desktop -t "$pkgdir"/usr/share/applications/
- mkdir -p "$pkgdir"/usr/share/doc/bash-config/help
- cp -r help/* "$pkgdir"/usr/share/doc/bash-config/help
+ # the "install" target in the makefile does nothing, copying manually
+ install -Dm755 bash-config -t "$pkgdir"/usr/bin/
+ install -Dm644 bashrc-config.desktop "$pkgdir"/usr/share/applications/bash-config.desktop
+ install -Dm644 help/* -t "$pkgdir"/usr/share/doc/bash-config/help/
install -Dm644 "$srcdir"/fancy-prompts.bash -t "$pkgdir"/usr/share/bash-config/
}