summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2022-04-07 22:23:22 +0200
committeretckeeper2022-05-06 14:37:34 +0200
commit175b823b9c75c7582a6eec0f93cb5cd03ab2c22c (patch)
treee7172d27a0cb5c6a97f05ccd2d8ca9cfba72dd3a
parent1920db1ba118e8e3bb57ba91cebb949946ab5f6e (diff)
downloadaur-175b823b9c75c7582a6eec0f93cb5cd03ab2c22c.tar.gz
updated upstream url
added !strip to options array
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c00d8f10a6f..9ad28b73cfe5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mx-puppet-discord-git
pkgdesc = This is a Matrix bridge for Discord
- pkgver = r248.c17384a
- pkgrel = 4
- url = https://github.com/matrix-discord/mx-puppet-discord
+ pkgver = r276.3c82530
+ pkgrel = 1
+ url = https://gitlab.com/mx-puppet/discord/mx-puppet-discord.git
install = mx-puppet-discord.install
arch = x86_64
arch = armv7h
+ arch = aarch64
license = apache
makedepends = git
makedepends = npm
@@ -15,8 +16,9 @@ pkgbase = mx-puppet-discord-git
depends = libjpeg-turbo
provides = mx-puppet-discord
conflicts = mx-puppet-discord
+ options = !strip
backup = etc/mx-puppet-discord/config.yaml
- source = git+https://github.com/matrix-discord/mx-puppet-discord
+ source = git+https://gitlab.com/mx-puppet/discord/mx-puppet-discord.git
source = mx-puppet-discord.tmpfiles
source = mx-puppet-discord.sysusers
source = mx-puppet-discord.service
@@ -26,4 +28,3 @@ pkgbase = mx-puppet-discord-git
sha256sums = 81c81f60a3db42f840e70d1ca55a84e2655227a0b0f5ff99b6beff582a9e6964
pkgname = mx-puppet-discord-git
-
diff --git a/PKGBUILD b/PKGBUILD
index ebe820580ff3..dcecd2cd414f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
pkgname=mx-puppet-discord-git
-pkgver=r248.c17384a
-pkgrel=4
+pkgver=r276.3c82530
+pkgrel=1
# strip the -git suffix from name
_dirname="${pkgname%-git}"
_basename="${pkgname%-git}"
pkgdesc='This is a Matrix bridge for Discord'
-arch=('x86_64' 'armv7h')
-url='https://github.com/matrix-discord/mx-puppet-discord'
+arch=('x86_64' 'armv7h' 'aarch64')
+url='https://gitlab.com/mx-puppet/discord/mx-puppet-discord.git'
license=('apache')
depends=('nodejs' 'cairo' 'pango' 'libjpeg-turbo')
source=("git+${url}" "${_basename}.tmpfiles" "${_basename}.sysusers" "${_basename}.service")
@@ -17,6 +17,8 @@ sha256sums=('SKIP'
backup=("etc/${_basename}/config.yaml")
install="${_basename}.install"
makedepends+=('git' 'npm')
+# some users likely have issues from strip exausting machine resources
+options=(!strip)
# conflict/provide the same package as the non -git version
provides=("${_basename}")
conflicts=("${_basename}")