summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGianluca Nitti2018-03-01 20:09:23 +0100
committerGianluca Nitti2018-03-01 20:09:23 +0100
commitff127fc80ebcfa27a35f540a9633689da4ff34e5 (patch)
tree954857a0e69173e4cc1a21a03927ca34671221d9
downloadaur-ff127fc80ebcfa27a35f540a9633689da4ff34e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..91e9d491b15f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mx3000control-git
+ pkgdesc = Unofficial configuration program for Perixx MX-3000 gaming mouse
+ pkgver = r41.b39cbf2
+ pkgrel = 1
+ url = https://github.com/gianluca-nitti/mx3000control
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = make
+ makedepends = pkg-config
+ depends = hidapi
+ source = git+https://github.com/gianluca-nitti/mx3000control.git
+ md5sums = SKIP
+
+pkgname = mx3000control-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99dbbe3cc768
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Gianluca Nitti <gianluca.nitti96@gmail.com>
+
+_pkgname=mx3000control
+pkgname=${_pkgname}-git
+pkgver=r41.b39cbf2
+pkgrel=1
+pkgdesc="Unofficial configuration program for Perixx MX-3000 gaming mouse"
+arch=('x86_64' 'i686')
+url="https://github.com/gianluca-nitti/mx3000control"
+license=('MIT')
+groups=()
+depends=('hidapi')
+makedepends=('git' 'make' 'pkg-config')
+replaces=()
+backup=()
+options=()
+install=
+source=('git+https://github.com/gianluca-nitti/mx3000control.git')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make PREFIX="$pkgdir/usr/" install
+ install -Dm 664 LICENSE "$pkgdir/usr/share/licenses/${pkgname}/LICENSE"
+}