summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-05-22 04:11:49 +0800
committerlilac2020-05-22 04:11:49 +0800
commit1e9424b2714da2625edb14b85a19e270ac915aff (patch)
tree911b8db08a4bfb99ef32c961807636ce0e25b4ef
parentc80336319e1a3e60178d815a48690e90d2a0c889 (diff)
downloadaur-1e9424b2714da2625edb14b85a19e270ac915aff.tar.gz
update by lilac
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD14
2 files changed, 27 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e6af162ab42..17de3c47e46e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mxnet-git
pkgdesc = A flexible and efficient library for deep learning
- pkgver = 2.0.0.r10976.8a5886a677
+ pkgver = 2.0.0.r11010.b0315f86f5
pkgrel = 1
url = http://mxnet.io/
arch = x86_64
@@ -13,6 +13,7 @@ pkgbase = mxnet-git
makedepends = git
makedepends = gtk3
makedepends = nccl
+ makedepends = opencv
makedepends = qt5-base
depends = curl
depends = double-conversion
@@ -20,18 +21,29 @@ pkgbase = mxnet-git
depends = intel-mkl
depends = intel-tbb
depends = libjpeg-turbo
- depends = opencv
depends = protobuf
depends = python-graphviz
depends = python-numpy
depends = python-requests
depends = zeromq
- provides = mxnet=2.0.0.r10976.8a5886a677
+ provides = mxnet=2.0.0.r11010.b0315f86f5
conflicts = mxnet
source = mxnet::git+https://github.com/apache/incubator-mxnet.git
sha512sums = SKIP
pkgname = mxnet-git
+ depends = curl
+ depends = double-conversion
+ depends = hdf5
+ depends = intel-mkl
+ depends = intel-tbb
+ depends = libjpeg-turbo
+ depends = protobuf
+ depends = python-graphviz
+ depends = python-numpy
+ depends = python-requests
+ depends = zeromq
+ depends = opencv
pkgname = mxnet-cuda-git
pkgdesc = A flexible and efficient library for deep learning (with CUDA)
@@ -41,7 +53,6 @@ pkgname = mxnet-cuda-git
depends = intel-mkl
depends = intel-tbb
depends = libjpeg-turbo
- depends = opencv
depends = protobuf
depends = python-graphviz
depends = python-numpy
@@ -50,8 +61,8 @@ pkgname = mxnet-cuda-git
depends = cuda
depends = cudnn
depends = nccl
- provides = mxnet=2.0.0.r10976.8a5886a677
- provides = mxnet-cuda=2.0.0.r10976.8a5886a677
+ provides = mxnet=2.0.0.r11010.b0315f86f5
+ provides = mxnet-cuda=2.0.0.r11010.b0315f86f5
conflicts = mxnet
conflicts = mxnet-cuda
diff --git a/PKGBUILD b/PKGBUILD
index d2c07752443d..a878331f4c96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _cudaarch="6.0;6.1;7.0;7.5"
_pkgname=mxnet
pkgname=('mxnet-git' 'mxnet-cuda-git')
_pkgver=2.0.0
-pkgver=2.0.0.r10976.8a5886a677
+pkgver=2.0.0.r11010.b0315f86f5
pkgrel=1
pkgdesc='A flexible and efficient library for deep learning'
arch=('x86_64')
@@ -18,7 +18,6 @@ depends=(
'intel-mkl'
'intel-tbb'
'libjpeg-turbo'
- 'opencv'
'protobuf'
'python-graphviz'
'python-numpy'
@@ -34,6 +33,7 @@ makedepends=(
'git'
'gtk3'
'nccl'
+ 'opencv'
'qt5-base'
)
provides=(mxnet=${pkgver})
@@ -70,7 +70,6 @@ build() {
cmake_opts=(
-DBUILD_CPP_EXAMPLES:BOOL=OFF
-DBUILD_TESTING:BOOL=OFF
- -DCMAKE_CUDA_HOST_COMPILER=/usr/bin/g++
-DCMAKE_INSTALL_LIBDIR:PATH=lib
-DCMAKE_INSTALL_PREFIX:PATH=/usr
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=ON
@@ -87,7 +86,6 @@ build() {
-DUSE_LIBJPEG_TURBO:BOOL=ON
-DUSE_MKLDNN:BOOL=ON
-DUSE_MKL_IF_AVAILABLE:BOOL=ON
- -DUSE_OPENCV:BOOL=ON
-DUSE_OPENMP:BOOL=ON
-DUSE_S3:BOOL=ON
)
@@ -96,10 +94,14 @@ build() {
cd "${srcdir}/mxnet-cuda-git/build"
cmake \
${cmake_opts[@]} \
+ -DCMAKE_C_COMPILER=/opt/cuda/bin/gcc \
+ -DCMAKE_CXX_COMPILER=/opt/cuda/bin/g++ \
+ -DCMAKE_CUDA_HOST_COMPILER=/opt/cuda/bin/g++ \
-DMXNET_CUDA_ARCH=${_cudaarch} \
-DUSE_CUDA:BOOL=ON \
-DUSE_CUDNN:BOOL=ON \
-DUSE_NCCL:BOOL=ON \
+ -DUSE_OPENCV:BOOL=OFF \
..
make
cd ../python
@@ -113,6 +115,7 @@ build() {
-DUSE_CUDA:BOOL=OFF \
-DUSE_CUDNN:BOOL=OFF \
-DUSE_NCCL:BOOL=OFF \
+ -DUSE_OPENCV:BOOL=ON \
..
make
cd ../python
@@ -140,6 +143,7 @@ _package() {
ln -s "/usr/include" "${pkgdir}/usr/lib/python$(get_pyver)/site-packages/mxnet/include"
# remove unwantted files
+ rm -rfv "${pkgdir}/mkldnn"
rm -rfv "${pkgdir}/usr/mxnet"
rm -rfv "${pkgdir}/usr/lib/cmake" "${pkgdir}/usr/share/doc"
find "${pkgdir}" -type f -name '*dnn*' -delete
@@ -148,6 +152,8 @@ _package() {
package_mxnet-git() {
+ depends+=(opencv)
+
_package
}