summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2020-04-08 11:57:03 +0800
committerlilac2020-04-08 11:57:03 +0800
commit2863478c5f0b063a95c62ad357c5d776d7eefc3c (patch)
treeb83a2495bec91f94ae66f5ad93277edb3a051ba1
parent3938f9aa7c6887054a6615f19df55eb782cea1d5 (diff)
downloadaur-2863478c5f0b063a95c62ad357c5d776d7eefc3c.tar.gz
update by lilac
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD18
2 files changed, 11 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8f573b6b2e5..86ce21dd79d4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mxnet-git
pkgdesc = A flexible and efficient library for deep learning
- pkgver = 2.0.0.r10824.08528c5cb9
+ pkgver = 2.0.0.r10843.b7f7525cba
pkgrel = 1
url = http://mxnet.io/
arch = x86_64
@@ -12,35 +12,24 @@ pkgbase = mxnet-git
makedepends = git
makedepends = gtk3
makedepends = nccl
- makedepends = opencv
makedepends = qt5-base
depends = curl
depends = double-conversion
depends = hdf5
depends = intel-mkl
depends = intel-tbb
+ depends = opencv
depends = protobuf
depends = python-graphviz
depends = python-numpy
depends = python-requests
depends = zeromq
- provides = mxnet=2.0.0.r10824.08528c5cb9
+ provides = mxnet=2.0.0.r10843.b7f7525cba
conflicts = mxnet
source = mxnet::git+https://github.com/apache/incubator-mxnet.git
sha512sums = SKIP
pkgname = mxnet-git
- depends = curl
- depends = double-conversion
- depends = hdf5
- depends = intel-mkl
- depends = intel-tbb
- depends = protobuf
- depends = python-graphviz
- depends = python-numpy
- depends = python-requests
- depends = zeromq
- depends = opencv
pkgname = mxnet-cuda-git
pkgdesc = A flexible and efficient library for deep learning (with CUDA)
@@ -49,6 +38,7 @@ pkgname = mxnet-cuda-git
depends = hdf5
depends = intel-mkl
depends = intel-tbb
+ depends = opencv
depends = protobuf
depends = python-graphviz
depends = python-numpy
@@ -57,8 +47,8 @@ pkgname = mxnet-cuda-git
depends = cuda
depends = cudnn
depends = nccl
- provides = mxnet=2.0.0.r10824.08528c5cb9
- provides = mxnet-cuda=2.0.0.r10824.08528c5cb9
+ provides = mxnet=2.0.0.r10843.b7f7525cba
+ provides = mxnet-cuda=2.0.0.r10843.b7f7525cba
conflicts = mxnet
- conflicts = mxnet-cuda=2.0.0.r10824.08528c5cb9
+ conflicts = mxnet-cuda=2.0.0.r10843.b7f7525cba
diff --git a/PKGBUILD b/PKGBUILD
index 74b8c21667ff..78e115da9f90 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _cudaarch="6.0;6.1;7.0;7.5"
_pkgname=mxnet
pkgname=('mxnet-git' 'mxnet-cuda-git')
_pkgver=2.0.0
-pkgver=2.0.0.r10824.08528c5cb9
+pkgver=2.0.0.r10843.b7f7525cba
pkgrel=1
pkgdesc='A flexible and efficient library for deep learning'
arch=('x86_64')
@@ -17,6 +17,7 @@ depends=(
'hdf5'
'intel-mkl'
'intel-tbb'
+ 'opencv'
'protobuf'
'python-graphviz'
'python-numpy'
@@ -31,7 +32,6 @@ makedepends=(
'git'
'gtk3'
'nccl'
- 'opencv'
'qt5-base'
)
provides=(mxnet=${pkgver})
@@ -68,6 +68,7 @@ build() {
cmake_opts=(
-DBUILD_CPP_EXAMPLES:BOOL=OFF
-DBUILD_TESTING:BOOL=OFF
+ -DCMAKE_CUDA_HOST_COMPILER=/usr/bin/g++
-DCMAKE_INSTALL_LIBDIR:PATH=lib
-DCMAKE_INSTALL_PREFIX:PATH=/usr
-DCMAKE_SKIP_INSTALL_RPATH:BOOL=ON
@@ -82,13 +83,12 @@ build() {
-DUSE_LAPACK:BOOL=ON
-DUSE_MKLDNN:BOOL=ON
-DUSE_MKL_IF_AVAILABLE:BOOL=ON
+ -DUSE_OPENCV:BOOL=ON
-DUSE_OPENMP:BOOL=ON
-DUSE_S3:BOOL=ON
)
# use gcc version compatible with CUDA
- export CC=/opt/cuda/bin/gcc
- export CXX=/opt/cuda/bin/g++
# building with CUDA
cd "${srcdir}/mxnet-cuda-git/build"
@@ -98,14 +98,11 @@ build() {
-DUSE_CUDA:BOOL=ON \
-DUSE_CUDNN:BOOL=ON \
-DUSE_NCCL:BOOL=ON \
- -DUSE_OPENCV:BOOL=OFF \
..
make
cd ../python
python setup.py build --with-cython
- export CC=gcc
- export CXX=g++
# building without CUDA
cd "${srcdir}/mxnet-git/build"
@@ -114,7 +111,6 @@ build() {
-DUSE_CUDA:BOOL=OFF \
-DUSE_CUDNN:BOOL=OFF \
-DUSE_NCCL:BOOL=OFF \
- -DUSE_OPENCV:BOOL=ON \
..
make
cd ../python
@@ -150,10 +146,6 @@ _package() {
package_mxnet-git() {
- depends+=(opencv)
-
- export CC=gcc
- export CXX=g++
_package
}
@@ -163,8 +155,6 @@ package_mxnet-cuda-git() {
provides+=(mxnet-cuda=${pkgver})
conflicts+=(mxnet-cuda=${pkgver})
- export CC=/opt/cuda/bin/gcc
- export CXX=/opt/cuda/bin/g++
_package
}