summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-14 16:50:26 +0800
committerzxp198210052024-03-14 16:50:26 +0800
commit282242f649ec87c843744d9416c196f85743e445 (patch)
treeaba1e73e1498a49d3e1d078c52d7e9a3a056543a
parent5a639a983cc389267f555af3aa0cb59a95e22cdd (diff)
downloadaur-282242f649ec87c843744d9416c196f85743e445.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
-rw-r--r--my-hardware.sh8
3 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f5eb87b25cc..846902e1748e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = my-hardware-bin
pkgdesc = A cross-platform desktop app built with Electron using Angular v16 with Signals and provides nice UI/UX Charts for monitoring CPU, Memory, and Disk usage.
pkgver = 1.0.0
- pkgrel = 6
+ pkgrel = 7
url = https://github.com/Y-Moshe/my-hardware
arch = x86_64
license = MIT
- depends = electron25
+ depends = electron25-bin
provides = my-hardware=1.0.0
conflicts = my-hardware
source = my-hardware-1.0.0.deb::https://github.com/Y-Moshe/my-hardware/releases/download/v1.0.0/my-hardware_1.0.0_amd64.deb
source = my-hardware.sh
sha256sums = a5cd8a0df8b8989cd94c023aba7b5d39644a52a517f41c713f20a2b34420fcbd
- sha256sums = 0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
pkgname = my-hardware-bin
diff --git a/PKGBUILD b/PKGBUILD
index 0a99a47513dc..e056f77d8118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=my-hardware-bin
pkgver=1.0.0
_electronversion=25
-pkgrel=6
+pkgrel=7
pkgdesc="A cross-platform desktop app built with Electron using Angular v16 with Signals and provides nice UI/UX Charts for monitoring CPU, Memory, and Disk usage."
arch=('x86_64')
url="https://github.com/Y-Moshe/my-hardware"
@@ -10,18 +10,19 @@ license=('MIT')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
- "electron${_electronversion}"
+ "electron${_electronversion}-bin"
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
"${pkgname%-bin}.sh"
)
sha256sums=('a5cd8a0df8b8989cd94c023aba7b5d39644a52a517f41c713f20a2b34420fcbd'
- '0fb7b939a071f4a08476bdd5aa143d2aa8cd335c83309f9919be16cd5c3e2014')
+ 'dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data."*
}
diff --git a/my-hardware.sh b/my-hardware.sh
index f9ced1432cfc..7ddcaab8d734 100644
--- a/my-hardware.sh
+++ b/my-hardware.sh
@@ -1,14 +1,16 @@
-#!/bin/sh
+#!/bin/bash
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
+export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file