summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Devlamynck2016-04-19 22:58:44 +0200
committerMatthias Devlamynck2016-04-19 22:58:44 +0200
commit74fe2c759248a8f7d1b4a85e624479912e9acbb6 (patch)
tree76e08cca946414fa5d1ba8efa789213c5bc4ab8a
parent82fb581154b42de5db5801a910288b7faf849b5a (diff)
downloadaur-74fe2c759248a8f7d1b4a85e624479912e9acbb6.tar.gz
Update to 1.1.1 with my patches
-rwxr-xr-x.SRCINFO10
-rwxr-xr-xPKGBUILD24
2 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9af8478defa3..c7bd655a6866 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = my-little-investigations
pkgdesc = An Ace Attorney like game based on My Little Pony : Friendship is Magic
- pkgver = 1.0.10
+ pkgver = 1.1.1
pkgrel = 1
url = http://www.equestriandreamers.com/
install = mli.install
@@ -16,12 +16,10 @@ pkgbase = my-little-investigations
depends = ffmpeg
depends = crypto++
replaces = my-little-investigation
- source = git+https://github.com/GabuEx/my-little-investigations.git
- source = http://www.art-software.fr/files/MLI/common_data-1.0.10.tar.xz
- source = http://www.art-software.fr/files/MLI/needed_to_package-1.0.10.tar.xz
+ source = git+https://github.com/mdevlamynck/my-little-investigations.git
+ source = http://www.art-software.fr/files/MLI/common_data-1.1.1.tar.xz
md5sums = SKIP
- md5sums = 31979e9fbd4c3d8cc8f263e7cbab9250
- md5sums = 51618407c55334d4cf6be38ec51318e6
+ md5sums = f1fdbbb7306065a46edf0a9932360b64
pkgname = my-little-investigations
diff --git a/PKGBUILD b/PKGBUILD
index 283fb1980fdc..9018a6f32365 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
# Thanks to art-software for hosting extra files
pkgname=my-little-investigations
-_gitrepo=https://github.com/GabuEx/${pkgname}.git
-pkgver=1.0.10
+_gitrepo=https://github.com/mdevlamynck/${pkgname}.git
+#_gitrepo=https://github.com/GabuEx/${pkgname}.git
+pkgver=1.1.1
pkgrel=1
pkgdesc="An Ace Attorney like game based on My Little Pony : Friendship is Magic"
arch=('i686' 'x86_64')
@@ -18,21 +19,21 @@ install=mli.install
source=(
"git+${_gitrepo}"
"http://www.art-software.fr/files/MLI/common_data-${pkgver}.tar.xz"
- "http://www.art-software.fr/files/MLI/needed_to_package-${pkgver}.tar.xz"
+ #"http://www.art-software.fr/files/MLI/needed_to_package-${pkgver}.tar.xz"
)
md5sums=(
'SKIP'
- '31979e9fbd4c3d8cc8f263e7cbab9250'
- '51618407c55334d4cf6be38ec51318e6'
+ 'f1fdbbb7306065a46edf0a9932360b64'
+ #'e5d48f2eec8c55b8eb51bb573fe1d4eb'
)
build () {
cd "${srcdir}/${pkgname}"
- git checkout e8cf963bf5b731f578500d227bf66bef05d24fe3
+ git checkout $pkgver
- mkdir -p cmake
- mv "${srcdir}/needed_to_package/CMakeLists.txt" "${srcdir}/${pkgname}"
- mv "${srcdir}/needed_to_package/"Find*.cmake "${srcdir}/${pkgname}/cmake"
+ #mkdir -p cmake
+ #mv "${srcdir}/needed_to_package/CMakeLists.txt" "${srcdir}/${pkgname}"
+ #mv "${srcdir}/needed_to_package/"Find*.cmake "${srcdir}/${pkgname}/cmake"
mkdir -p build
cd build
@@ -48,9 +49,12 @@ package() {
cd "${srcdir}/${pkgname}/build"
install -D -m 755 MyLittleInvestigations "${pkgdir}/usr/bin/MyLittleInvestigations"
- cd "${srcdir}/needed_to_package"
+ cd "${srcdir}/${pkgname}/needed_to_package"
install -D -m 644 MyLittleInvestigations.desktop "${pkgdir}/usr/share/applications/MyLittleInvestigations.desktop"
+ #cd "${srcdir}/needed_to_package"
+ #install -D -m 644 MyLittleInvestigations.desktop "${pkgdir}/usr/share/applications/MyLittleInvestigations.desktop"
+
cd "${srcdir}/${pkgname}"
install -D -m 644 mli.png "${pkgdir}/usr/share/MyLittleInvestigations/mli.png"