summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthias Devlamynck2015-06-12 21:17:37 +0200
committerMatthias Devlamynck2015-06-12 21:18:07 +0200
commit82fb581154b42de5db5801a910288b7faf849b5a (patch)
treefd429abd8b6317c1286a06838af43b264cbe01c4
downloadaur-82fb581154b42de5db5801a910288b7faf849b5a.tar.gz
Initial Commit, import package
-rwxr-xr-x.SRCINFO27
-rwxr-xr-x.gitignore5
-rwxr-xr-xPKGBUILD64
-rwxr-xr-xmli.install32
4 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..9af8478defa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = my-little-investigations
+ pkgdesc = An Ace Attorney like game based on My Little Pony : Friendship is Magic
+ pkgver = 1.0.10
+ pkgrel = 1
+ url = http://www.equestriandreamers.com/
+ install = mli.install
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ depends = sdl2
+ depends = sdl2_image
+ depends = sdl2_ttf
+ depends = sdl2_mixer
+ depends = ffmpeg
+ depends = crypto++
+ replaces = my-little-investigation
+ source = git+https://github.com/GabuEx/my-little-investigations.git
+ source = http://www.art-software.fr/files/MLI/common_data-1.0.10.tar.xz
+ source = http://www.art-software.fr/files/MLI/needed_to_package-1.0.10.tar.xz
+ md5sums = SKIP
+ md5sums = 31979e9fbd4c3d8cc8f263e7cbab9250
+ md5sums = 51618407c55334d4cf6be38ec51318e6
+
+pkgname = my-little-investigations
+
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..2f536da8d828
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!.gitignore
+!mli.install
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..283fb1980fdc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+
+# Maintainer : mdevlamynck <matthias.devlamynck@mailoo.org>
+# Thanks to art-software for hosting extra files
+
+pkgname=my-little-investigations
+_gitrepo=https://github.com/GabuEx/${pkgname}.git
+pkgver=1.0.10
+pkgrel=1
+pkgdesc="An Ace Attorney like game based on My Little Pony : Friendship is Magic"
+arch=('i686' 'x86_64')
+url="http://www.equestriandreamers.com/"
+license=('MIT')
+groups=('')
+replaces=('my-little-investigation')
+depends=('sdl2' 'sdl2_image' 'sdl2_ttf' 'sdl2_mixer' 'ffmpeg' 'crypto++') # 'xdelta3')
+makedepends=('cmake' 'git')
+install=mli.install
+source=(
+ "git+${_gitrepo}"
+ "http://www.art-software.fr/files/MLI/common_data-${pkgver}.tar.xz"
+ "http://www.art-software.fr/files/MLI/needed_to_package-${pkgver}.tar.xz"
+)
+md5sums=(
+ 'SKIP'
+ '31979e9fbd4c3d8cc8f263e7cbab9250'
+ '51618407c55334d4cf6be38ec51318e6'
+)
+
+build () {
+ cd "${srcdir}/${pkgname}"
+ git checkout e8cf963bf5b731f578500d227bf66bef05d24fe3
+
+ mkdir -p cmake
+ mv "${srcdir}/needed_to_package/CMakeLists.txt" "${srcdir}/${pkgname}"
+ mv "${srcdir}/needed_to_package/"Find*.cmake "${srcdir}/${pkgname}/cmake"
+
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_BUILD_TYPE=Release
+ make MyLittleInvestigations
+
+ cd "${srcdir}/${pkgname}"
+ convert mli.ico mli.png
+ mv mli-0.png mli.png
+}
+
+package() {
+ cd "${srcdir}/${pkgname}/build"
+ install -D -m 755 MyLittleInvestigations "${pkgdir}/usr/bin/MyLittleInvestigations"
+
+ cd "${srcdir}/needed_to_package"
+ install -D -m 644 MyLittleInvestigations.desktop "${pkgdir}/usr/share/applications/MyLittleInvestigations.desktop"
+
+ cd "${srcdir}/${pkgname}"
+ install -D -m 644 mli.png "${pkgdir}/usr/share/MyLittleInvestigations/mli.png"
+
+ for file in $(find "${srcdir}/common_data" -type f)
+ do
+ install -D -m 644 "${file}" "${pkgdir}/usr/share/MyLittleInvestigations/${file#"${srcdir}/common_data"}"
+ done
+
+ echo ${pkgver} > "${pkgdir}/usr/share/MyLittleInvestigations/.version"
+}
+
diff --git a/mli.install b/mli.install
new file mode 100755
index 000000000000..2bee70f9fc93
--- /dev/null
+++ b/mli.install
@@ -0,0 +1,32 @@
+move_saves_one_user()
+{
+ user="$1"
+ base_path="$2""/test"
+ src_path="$base_path""/.local/share/EquestrianDreamers/MyLittleInvestigations"
+ dest_path="$base_path""/.MyLittleInvestigations"
+
+ [ -d "$src_path" -a ! -e "$dest_path" ] && \
+ {
+ cp --preserve -r "$src_path" "$dest_path" && \
+ rm "$src_path" -r
+ }
+}
+
+move_saves()
+{
+ A=" "
+ cut -d: -f1,6 /etc/passwd | \
+ grep -v '^//' | \
+ while [ "$A" != "" ]
+ do
+ read A
+ [[ "$A" != "" ]] && \
+ move_saves_one_user "${A%:*}" "${A#*:}"
+ done
+}
+
+post_upgrade()
+{
+ [[ $1 < "1.0.5-1" ]] && [[ $2 > "1.0.4-1" ]] && move_saves
+ return 0
+}