summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuigi Guevara2016-09-13 13:04:01 +0200
committerLuigi Guevara2016-09-13 13:04:01 +0200
commit2bb78239e9a078bbce8a1bebe9c5355d63552b4a (patch)
tree4a090ae5e489a4cad91f939a02e8f80f541335f8
downloadaur-2bb78239e9a078bbce8a1bebe9c5355d63552b4a.tar.gz
First buiÃld, to try out the install process
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD32
-rw-r--r--my-weather-indicator.install16
3 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c297e35dab74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = my-weather-indicator
+ pkgdesc = A simple indicator for the weather
+ pkgver = r44.sfg43sd
+ pkgrel = 1
+ url = https://launchpad.net/my-weather-indicator
+ install = my-weather-indicator.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = libappindicator-gtk3
+ depends = gtk3
+ depends = glib2
+ depends = libnotify
+ depends = webkitgtk
+ depends = geocode-glib
+ depends = python-pytz
+ depends = python-cairo
+ depends = python-lxml
+ depends = python-dateutil
+ depends = python2-requests-oauthlib
+ depends = geoclue2
+ depends = geoip
+ provides = my-weather-indicator
+ conflicts = my-weather-indicator
+ source = git+https://git.launchpad.net/my-weather-indicator
+ sha256sums = SKIP
+
+pkgname = my-weather-indicator
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..060c50a0d19c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Luigi Guevara <@killua99>
+
+pkgname=my-weather-indicator
+pkgver=r44.sfg43sd
+pkgrel=1
+pkgdesc='A simple indicator for the weather'
+arch=('i686' 'x86_64')
+url='https://launchpad.net/my-weather-indicator'
+license=('GPL3')
+depends=('gtk3' 'glib2' 'libnotify' 'webkitgtk' 'geocode-glib' 'python-pytz'
+ 'python-cairo' 'python-lxml' 'python-dateutil'
+ 'python2-requests-oauthlib' 'geoclue2' 'geoip')
+makedepends=('git' 'libappindicator-gtk3')
+provides=('my-weather-indicator')
+conflicts=('my-weather-indicator')
+install='my-weather-indicator.install'
+source=('git+https://git.launchpad.net/my-weather-indicator')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+
+package() {
+ cd $pkgname
+
+ install -D -m644 "${pkgdir}/opt/${$pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et:
diff --git a/my-weather-indicator.install b/my-weather-indicator.install
new file mode 100644
index 000000000000..b1b744355dff
--- /dev/null
+++ b/my-weather-indicator.install
@@ -0,0 +1,16 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ update-desktop-database -q
+}
+
+post_upgrade()
+{
+ post_install
+}
+
+post_remove()
+{
+ post_install
+}
+
+# vim: ts=2 sw=2 et: