summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2023-01-29 10:19:38 +0100
committerMattia Borda2023-01-29 10:19:38 +0100
commit9a235eff06869e5d20587470cf6668a25bfad308 (patch)
tree11c6d4fd966bc1d456bbb1b99e207c5f95bff1f5
parent19587ad04dd7642e4c9519c89ad2ad98b28cb234 (diff)
downloadaur-9a235eff06869e5d20587470cf6668a25bfad308.tar.gz
Update to 7.5.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 19 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d67fec1eeefd..481621b526d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = mybsmart
pkgdesc = Una piattaforma proprietaria di servizi e contenuti digitali per la scuola
- pkgver = 7.4.10
+ pkgver = 7.5.0
pkgrel = 1
- url = https://www.bsmart.it
+ url = https://bsmart.it
arch = i686
arch = x86_64
license = custom
+ depends = ffmpeg
depends = gtk3
depends = libnotify
depends = nss
@@ -14,13 +15,12 @@ pkgbase = mybsmart
depends = xdg-utils
depends = python-atspi
depends = util-linux-libs
- depends = libappindicator-gtk3
depends = libsecret
source = LICENSE
sha256sums = 2ca3e6e7951873c7d82829299181838bb7cacb5c2ad372d7ce752d6d10543b39
- source_i686 = https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-7.4.10-ia32.deb
- sha256sums_i686 = 6577cde026eac95c2fa9f5d4a9f657ca2e2da89e802dc659de4bbb97ff7ac4bf
- source_x86_64 = https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-7.4.10-x64.deb
- sha256sums_x86_64 = d38945f56a0df50d47e2fdef4eb55d0884f5c129210f21833773d66d31caa26b
+ source_i686 = https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-7.5.0-ia32.deb
+ sha256sums_i686 = ee619c2ae1973a02863ec0b0fb4432e256802828612c429013739681de15fae9
+ source_x86_64 = https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-7.5.0-x64.deb
+ sha256sums_x86_64 = 1d4169619e03ef45c7f91efbfcdc785272a67e85b44a127676145f6a802bf208
pkgname = mybsmart
diff --git a/PKGBUILD b/PKGBUILD
index 74eb8bc3b511..2ba3b8929a39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,27 @@
-# Maintainer: musiclover <musiclover382@protonmail.com>
-# Contributor: Valerio Pizzi (pival81) <pival81@yahoo.com>
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+# Contributor: Valerio Pizzi <pival81@yahoo.com>
pkgname=mybsmart
-pkgver=7.4.10
+pkgver=7.5.0
pkgrel=1
pkgdesc="Una piattaforma proprietaria di servizi e contenuti digitali per la scuola"
-arch=("i686" "x86_64")
-url="https://www.bsmart.it"
-depends=('gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'python-atspi' 'util-linux-libs' 'libappindicator-gtk3' 'libsecret')
-license=('custom')
-source=('LICENSE')
-source_i686=("https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-$pkgver-ia32.deb")
-source_x86_64=("https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-$pkgver-x64.deb")
+arch=('i686' 'x86_64')
+url="https://bsmart.it"
+depends=('ffmpeg' 'gtk3' 'libnotify' 'nss' 'libxss' 'libxtst' 'xdg-utils' 'python-atspi' 'util-linux-libs' 'libsecret')
+license=(custom)
+source=(LICENSE)
+source_i686=(https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-$pkgver-ia32.deb)
+source_x86_64=(https://s3-eu-west-1.amazonaws.com/res.bsmart.it/mybsmart_desktop/releases/production_v2/linux/MybSmart-$pkgver-x64.deb)
sha256sums=('2ca3e6e7951873c7d82829299181838bb7cacb5c2ad372d7ce752d6d10543b39')
-sha256sums_i686=('6577cde026eac95c2fa9f5d4a9f657ca2e2da89e802dc659de4bbb97ff7ac4bf')
-sha256sums_x86_64=('d38945f56a0df50d47e2fdef4eb55d0884f5c129210f21833773d66d31caa26b')
+sha256sums_i686=('ee619c2ae1973a02863ec0b0fb4432e256802828612c429013739681de15fae9')
+sha256sums_x86_64=('1d4169619e03ef45c7f91efbfcdc785272a67e85b44a127676145f6a802bf208')
package() {
tar -xf data.tar.xz --exclude='./usr/share/doc' -C "$pkgdir"
-
- # Link binary
mkdir "$pkgdir"/usr/bin
ln -sf /opt/MybSmart/$pkgname "$pkgdir"/usr/bin/$pkgname
-
# SUID chrome-sandbox for Electron 5+
chmod 4755 "$pkgdir"/opt/MybSmart/chrome-sandbox || true
-
- # Install license
# https://www.bsmart.it/pages/terminiecondizioni
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}