summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNyxxie2017-01-08 19:56:50 -0600
committerNyxxie2017-01-08 19:56:50 -0600
commit5983773b8eae621889dac41d7c6c11bbb0950e7c (patch)
treeeee6d3a8ce3e708aa481a191969e2b300962238f
downloadaur-5983773b8eae621889dac41d7c6c11bbb0950e7c.tar.gz
Initial upload to AUR.
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD32
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..db4c8f49adb0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = mycroft
+ pkgver = 0.1
+ pkgrel = 1
+ url = github.com/nyxxxie/mycroft
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = make
+ makedepends = cmake
+ depends = sqlite
+ depends = capstone
+ depends = python
+ depends = openssl
+ depends = gtest
+ depends = qt5-base
+ optdepends = graphviz: doxygen graph support
+ provides = qmycroft
+ provides = libmycroft_core
+ source = git+https://github.com/nyxxxie/mycroft.git
+ sha256sums = SKIP
+
+pkgname = mycroft
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8347749b47ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nyxxie <nyxxie@protonmail.ch>
+pkgname=mycroft
+pkgver=0.1
+pkgrel=1
+pkgdesc=""
+url="github.com/nyxxxie/mycroft"
+arch=('i686' 'x86_64')
+license=('GPL')
+depends=('sqlite' 'capstone' 'python' 'openssl' 'gtest' 'qt5-base')
+optdepends=('graphviz: doxygen graph support')
+makedepends=('make' 'cmake')
+provides=('qmycroft' 'libmycroft_core')
+conflicts=()
+replaces=()
+backup=()
+source=("git+https://github.com/nyxxxie/mycroft.git")
+sha256sums=('SKIP')
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../$pkgname \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+package() {
+ cd build
+ make DESTDIR="$pkgdir" install
+}