summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRafael Reggiani Manzo2016-12-26 21:28:36 -0200
committerRafael Reggiani Manzo2016-12-26 21:28:36 -0200
commitb5ad673a5bab0dfe7f83459ffe5317e0cca9f3f3 (patch)
tree72ce9f089f9d815a138d9979acf34127b53d6d9c
parent43703ca016da5f30206c708d6595657d354dc3e2 (diff)
downloadaur-b5ad673a5bab0dfe7f83459ffe5317e0cca9f3f3.tar.gz
Fix missing mimic binary
Mycroft looks for it only under its own root and not the default system paths.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c39ec06f179a..be57f9402890 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Mon Dec 26 23:10:27 UTC 2016
+# Mon Dec 26 23:28:24 UTC 2016
pkgbase = mycroft-core
pkgdesc = Mycroft Core, the Mycroft Artificial Intelligence platform. Contribute to this package at: https://gitlab.com/rafamanzo/aur-mycroft-core
pkgver = 0.7.20.eb0a37c
diff --git a/PKGBUILD b/PKGBUILD
index 7129a0d31389..cadf41f1fd19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -49,4 +49,8 @@ sha512sums=(SKIP) # Git already ensures data consistency
package() {
mkdir -p ${pkgdir}/usr/share/
cp -R mycroft-core ${pkgdir}/usr/share/
+
+ # Place a link to mimic where mycroft is expecting it
+ mkdir -p ${pkgdir}/usr/share/mycroft-core/mimic/bin
+ ln -s /usr/bin/mimic ${pkgdir}/usr/share/mycroft-core/mimic/bin/mimic
}