summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxsmile2018-08-31 12:24:43 +0200
committerxsmile2018-08-31 12:24:43 +0200
commita7374ed87bf213d0a7550620cbbdaeca614c0381 (patch)
treeb2ba9f5fec468c73d1ba77ea61585f10d9392058
downloadaur-a7374ed87bf213d0a7550620cbbdaeca614c0381.tar.gz
1.2.2
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore8
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD47
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3206c029fcb6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mycrypto-bin
+ pkgdesc = Open-source, client-side tool for generating Ether Wallets, handling ERC-20 tokens, and interacting with the blockchain more easily
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/MyCryptoHQ/MyCrypto
+ arch = x86_64
+ license = MIT
+ depends = gconf
+ depends = gtk3
+ depends = libxss
+ depends = nss
+ provides = mycrypto
+ conflicts = mycrypto
+ source = https://github.com/MyCryptoHQ/MyCrypto/releases/download/1.2.2/linux-x86-64_1.2.2_MyCrypto.AppImage
+ source = LICENSE
+ sha256sums = e4a41f64f0b070faf0ea2656ab13700f6a706511afcd79378470786c9eccb33f
+ sha256sums = e4d52665623eaeb7d6efa43c0c29d225cd009cd766dc15f1b464a19cab1ec5cb
+
+pkgname = mycrypto-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1a1894d3dccb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/*
+src/*
+
+*.AppImage
+*.tar*
+
+*.asc
+*.sig
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..7b1edff2ad6f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+MIT License
+
+Copyright (c) 2015-2017 MyEtherWallet LLC
+Copyright (c) 2018 MyCrypto, Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6e9da08c25ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: xsmile <>
+
+pkgname=mycrypto-bin
+_pkgname=mycrypto
+pkgver=1.2.2
+pkgrel=1
+pkgdesc='Open-source, client-side tool for generating Ether Wallets, handling ERC-20 tokens, and interacting with the blockchain more easily'
+arch=('x86_64')
+depends=('gconf' 'gtk3' 'libxss' 'nss')
+provides=('mycrypto')
+conflicts=('mycrypto')
+url='https://github.com/MyCryptoHQ/MyCrypto'
+license=('MIT')
+source=("${url}/releases/download/${pkgver}/linux-x86-64_${pkgver}_MyCrypto.AppImage"
+ 'LICENSE')
+sha256sums=('e4a41f64f0b070faf0ea2656ab13700f6a706511afcd79378470786c9eccb33f'
+ 'e4d52665623eaeb7d6efa43c0c29d225cd009cd766dc15f1b464a19cab1ec5cb')
+
+prepare() {
+ # Extract AppImage
+ chmod +x linux-x86-64_${pkgver}_MyCrypto.AppImage
+ ./linux-x86-64_${pkgver}_MyCrypto.AppImage --appimage-extract &>/dev/null
+ mv squashfs-root $_pkgname-$pkgver
+}
+
+package() {
+ cd $_pkgname-$pkgver
+
+ # Lib directory
+ install -d "$pkgdir"/usr/lib/$_pkgname
+ cp -r app/{locales,resources,*.dat,*.pak,*.so,*.bin} "$pkgdir"/usr/lib/$_pkgname
+ install -Dm755 app/mycrypto -t "$pkgdir"/usr/lib/$_pkgname
+ # Desktop entry
+ sed -i s/AppRun/mycrypto/ mycrypto.desktop
+ install -Dm644 mycrypto.desktop -t "$pkgdir"/usr/share/applications
+ # Icon
+ install -Dm644 usr/share/icons/hicolor/0x0/apps/mycrypto.png \
+ -t "$pkgdir"/usr/share/icons/hicolor/256x256/apps
+ # Executable
+ install -d "$pkgdir"/usr/bin
+ ln -s /usr/lib/$_pkgname/mycrypto "$pkgdir"/usr/bin/$_pkgname
+ # Licenses
+ install -Dm644 "$srcdir"/LICENSE -t "$pkgdir"/usr/share/licenses/$_pkgname
+ cp -r app/{*.txt,*.html} "$pkgdir"/usr/share/licenses/$_pkgname
+ # Fix permissions
+ find "$pkgdir"/usr -type d -exec chmod 755 {} \;
+}