summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrien Prost-Boucle2016-01-08 22:54:50 +0100
committerAdrien Prost-Boucle2016-01-08 22:54:50 +0100
commitd99b4474b36bea3f9a9a3be1e3ab3e53af9f7cc8 (patch)
treea425f8301bfd1676b2f1dfaef4327581d4211189
downloadaur-d99b4474b36bea3f9a9a3be1e3ab3e53af9f7cc8.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD81
2 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..690b9329923e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by mksrcinfo v8
+# Fri Jan 8 21:54:25 UTC 2016
+pkgbase = mygui-gl-git
+ pkgdesc = A library for creating Graphical User Interfaces for games and 3D applications
+ pkgver = 3.2.3.git20151206
+ pkgrel = 1
+ url = http://mygui.info/
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = boost
+ makedepends = cmake
+ depends = boost-libs
+ depends = freetype2
+ depends = sdl2
+ depends = libgl
+ optdepends = mygui-docs: documentation
+ provides = mygui
+ conflicts = mygui
+ conflicts = mygui-git
+ source = git://github.com/MyGUI/mygui.git
+ md5sums = SKIP
+
+pkgname = mygui-gl-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13ccccd40e11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,81 @@
+# Maintainer: adrien Prost-Boucle <adrien.prost-boucle.@laposte.net>
+
+pkgname='mygui-gl-git'
+pkgver=3.2.3.git20151206
+pkgrel=1
+
+pkgdesc="A library for creating Graphical User Interfaces for games and 3D applications"
+arch=('i686' 'x86_64')
+url="http://mygui.info/"
+license=('LGPL')
+
+source=("git://github.com/MyGUI/mygui.git")
+md5sums=('SKIP')
+
+depends=('boost-libs' 'freetype2' 'sdl2' 'libgl')
+makedepends=('boost' 'cmake')
+optdepends=('mygui-docs: documentation')
+conflicts=('mygui' 'mygui-git')
+provides=('mygui')
+
+pkgver() {
+ cd "${srcdir}/mygui"
+
+ _hfile='MyGUIEngine/include/MyGUI_Prerequest.h'
+ _maj=`cat $_hfile | grep MYGUI_VERSION_MAJOR | head -n1 | awk '{print $3;}'`
+ _min=`cat $_hfile | grep MYGUI_VERSION_MINOR | head -n1 | awk '{print $3;}'`
+ _rev=`cat $_hfile | grep MYGUI_VERSION_PATCH | head -n1 | awk '{print $3;}'`
+
+ _gitlog=`git log -1 --format=%cd --date=short | tr -d '-'`
+ #git log -1 --format=%cd.%h --date=short | tr -d '-'
+
+ echo $_maj.$_min.$_rev.git$_gitlog
+}
+
+build() {
+ cd "${srcdir}/mygui"
+
+ msg "CMake config so demos install to /opt..."
+
+ sed -i 's:"bin:"../opt/MYGUI:' CMake/Utils/MyGUIConfigTargets.cmake
+ sed -i -e 's:../share:/usr/share:' \
+ -e 's:"bin":"../opt/MYGUI":' \
+ CMake/InstallResources.cmake
+ sed -i '71 i set(MYGUI_GCC_VISIBILITY_FLAGS "")' CMakeLists.txt
+ sed -i 's/\${OIS_LIBRARIES}/${OIS_LIBRARIES} boost_system/g' Common/CMakeLists.txt
+
+ msg "Get a clean build dir..."
+
+ rm -rf build
+ mkdir -p build
+ cd build
+
+ msg "Generate CMake makefiles..."
+
+ # Note: MYGUI_RENDERSYSTEM = 3 for Ogre, 4 for OpenGL
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMYGUI_INSTALL_SAMPLES=TRUE \
+ -DMYGUI_INSTALL_TOOLS=TRUE \
+ -DMYGUI_INSTALL_MEDIA=TRUE \
+ -DMYGUI_RENDERSYSTEM=4 \
+ -DFREETYPE_INCLUDE_DIR=/usr/include/freetype2/ \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DBUILD_SHARED_LIBS=TRUE
+
+ msg "Starting make..."
+
+ make
+}
+
+package() {
+ cd "${srcdir}/mygui/build"
+
+ make DESTDIR="$pkgdir" install
+
+ # make demos work
+ install -Dm775 lib/libCommon.so ${pkgdir}/usr/lib/libCommon.so
+ chown root:users $pkgdir/opt/MYGUI
+ chmod 775 $pkgdir/opt/MYGUI
+}
+