summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2016-04-29 10:30:52 -0700
committerAndy Weidenbaum2016-04-29 10:30:52 -0700
commit45bb7ad4f0bdeb5a1b3285a965031d8edc1241aa (patch)
treee4a5e38bc987d19639f5dc7840fb1656dd6738da
downloadaur-45bb7ad4f0bdeb5a1b3285a965031d8edc1241aa.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1aa4e4b1b8f9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Fri Apr 29 17:30:28 UTC 2016
+pkgbase = myhtml-git
+ pkgdesc = Fast HTML parser using threads implemented as a pure C99 library with no outside dependencies
+ pkgver = 20160420
+ pkgrel = 1
+ url = https://github.com/lexborisov/myhtml
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = git
+ makedepends = make
+ provides = myhtml
+ conflicts = myhtml
+ source = git+https://github.com/lexborisov/myhtml
+ sha256sums = SKIP
+
+pkgname = myhtml-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3589aae0b883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=myhtml-git
+pkgver=20160420
+pkgrel=1
+pkgdesc="Fast HTML parser using threads implemented as a pure C99 library with no outside dependencies"
+arch=('i686' 'x86_64')
+makedepends=('cmake' 'git' 'make')
+url="https://github.com/lexborisov/myhtml"
+license=('Apache')
+source=(git+https://github.com/lexborisov/myhtml)
+sha256sums=('SKIP')
+provides=('myhtml')
+conflicts=('myhtml')
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+build() {
+ cd ${pkgname%-git}
+
+ msg2 'Building...'
+ cd projects
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DMyHTML_INSTALL_HEADER=ON
+ make
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ cp -dpr --no-preserve=ownership docs/* examples \
+ "$pkgdir/usr/share/doc/${pkgname%-git}"
+
+ msg2 'Installing...'
+ make DESTDIR="$pkgdir" install -C projects/
+}