summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCoderPuppy2017-12-04 16:28:52 -0500
committerCoderPuppy2017-12-04 16:29:13 -0500
commitb5d2f6f789dceb850f1d45dab739ca34f1079b09 (patch)
tree3dd3bd1991d499dd782eed95d9022084105503bb
parent45bb7ad4f0bdeb5a1b3285a965031d8edc1241aa (diff)
downloadaur-b5d2f6f789dceb850f1d45dab739ca34f1079b09.tar.gz
Fixed it
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD39
2 files changed, 19 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1aa4e4b1b8f9..9854c0e29068 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,12 @@
-# Generated by mksrcinfo v8
-# Fri Apr 29 17:30:28 UTC 2016
pkgbase = myhtml-git
pkgdesc = Fast HTML parser using threads implemented as a pure C99 library with no outside dependencies
- pkgver = 20160420
+ pkgver = 20171204
pkgrel = 1
url = https://github.com/lexborisov/myhtml
arch = i686
arch = x86_64
- license = Apache
- makedepends = cmake
+ license = LGPL
makedepends = git
- makedepends = make
provides = myhtml
conflicts = myhtml
source = git+https://github.com/lexborisov/myhtml
diff --git a/PKGBUILD b/PKGBUILD
index 3589aae0b883..af5abb9b5332 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,37 @@
-# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
-
pkgname=myhtml-git
-pkgver=20160420
+pkgver=20171129
pkgrel=1
pkgdesc="Fast HTML parser using threads implemented as a pure C99 library with no outside dependencies"
arch=('i686' 'x86_64')
-makedepends=('cmake' 'git' 'make')
+makedepends=('git')
url="https://github.com/lexborisov/myhtml"
-license=('Apache')
+license=('LGPL')
source=(git+https://github.com/lexborisov/myhtml)
sha256sums=('SKIP')
provides=('myhtml')
conflicts=('myhtml')
pkgver() {
- cd ${pkgname%-git}
- git log -1 --format="%cd" --date=short | sed "s|-||g"
+ cd myhtml
+ git log -1 --format="%cd" --date=short | sed "s/-//g"
}
build() {
- cd ${pkgname%-git}
-
- msg2 'Building...'
- cd projects
- cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DMyHTML_INSTALL_HEADER=ON
- make
+ cd myhtml
+ msg2 'Building...'
+ make CFLAGS=-Wno-pedantic prefix=/usr
}
package() {
- cd ${pkgname%-git}
+ cd myhtml
+
+ msg2 'Installing license...'
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/${pkgname%-git}/LICENSE
- msg2 'Installing documentation...'
- install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
- cp -dpr --no-preserve=ownership docs/* examples \
- "$pkgdir/usr/share/doc/${pkgname%-git}"
+ msg2 'Installing documentation...'
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/${pkgname%-git}/README.md
+ cp -dpr --no-preserve=ownership examples "$pkgdir"/usr/share/doc/${pkgname%-git}
- msg2 'Installing...'
- make DESTDIR="$pkgdir" install -C projects/
+ msg2 'Installing...'
+ make prefix="$pkgdir/" install
}