summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Konovalov2021-01-03 19:22:42 +0500
committerVyacheslav Konovalov2021-01-03 19:22:42 +0500
commitb6eef569782921f7b0a34b4217c7a283f9b5ca76 (patch)
treef71f33ce506366849f8cf7bd91279015751434a0
downloadaur-b6eef569782921f7b0a34b4217c7a283f9b5ca76.tar.gz
Version 0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9120560cbbc0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = myip-rs
+ pkgdesc = A command-line tool to get your external IP address
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/crabvk/myip
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/crabvk/myip/archive/0.1.0.tar.gz
+ sha512sums = e9ea34abd8a380da5a188fcfa0352a938367e38bd731bc1356b112cff534a5934e1866eef8f83c40404f4e677c0d3c09fe06f520ffa9f0cbba96938f773e3298
+
+pkgname = myip-rs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e933ace74f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Vyacheslav Konovalov <f4f7l1hvr@relay.firefox.com>
+
+pkgname=myip-rs
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A command-line tool to get your external IP address'
+arch=('x86_64')
+url='https://github.com/crabvk/myip'
+license=('MIT')
+makedepends=('cargo')
+source=("https://github.com/crabvk/myip/archive/$pkgver.tar.gz")
+sha512sums=('e9ea34abd8a380da5a188fcfa0352a938367e38bd731bc1356b112cff534a5934e1866eef8f83c40404f4e677c0d3c09fe06f520ffa9f0cbba96938f773e3298')
+
+build() {
+ cd myip-$pkgver
+ cargo build --release --locked --target-dir=target
+}
+
+package() {
+ cd myip-$pkgver
+ install -Dm755 target/release/myip -t "$pkgdir"/usr/bin
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}