summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergio Correia2017-03-07 21:48:19 -0500
committerSergio Correia2017-03-07 21:48:19 -0500
commitf36c7686be32828b1b0d5d9cd206d4b4a3f1da12 (patch)
tree1c7589a64559e5eac63ec54decc6bebb78448d1e
downloadaur-f36c7686be32828b1b0d5d9cd206d4b4a3f1da12.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD41
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd7e0728fcab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+# Generated by makepkg 5.0.1
+# Wed Mar 8 02:41:38 UTC 2017
+pkgbase = mylaunchpad-git
+ pkgdesc = Eyecandy Full Screen launcher script for openbox and other stand-alone window managers
+ pkgver = r93.7bb98be
+ pkgrel = 1
+ url = https://github.com/gaboelnuevo/mylaunchpad
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2-lxml
+ depends = pygtk
+ depends = cairo
+ depends = python2-cairo
+ depends = python2-imaging
+ depends = gnome-menus2
+ depends = python2-distutils-extra
+ provides = mylaunchpad
+ conflicts = mylaunchpad
+ backup = etc/mylaunchpad.conf
+ source = mylaunchpad::git+http://github.com/gaboelnuevo/mylaunchpad
+ md5sums = SKIP
+
+pkgname = mylaunchpad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d818b1133d3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Sergio Correia <sergio@correia.cc>
+# Contributor: Gabriel Sabillon
+# Contributors: Tsarev Nikita, LoranKey
+
+# Set the following variable to true to use category icons instead of names
+_category_icons=false
+
+pkgname=mylaunchpad-git
+_pkgname_simple=mylaunchpad
+pkgdesc="Eyecandy Full Screen launcher script for openbox and other stand-alone window managers"
+pkgrel=1
+pkgver=r93.7bb98be
+
+arch=('any')
+url="https://github.com/gaboelnuevo/mylaunchpad"
+license=('GPL')
+depends=('python2-lxml' 'pygtk' 'cairo' 'python2-cairo' 'python2-imaging' 'gnome-menus2' 'python2-distutils-extra')
+makedepends=('git')
+provides=('mylaunchpad')
+conflicts=('mylaunchpad')
+md5sums=('SKIP')
+backup=('etc/mylaunchpad.conf')
+
+source=('mylaunchpad::git+http://github.com/gaboelnuevo/mylaunchpad')
+
+pkgver() {
+ cd "${srcdir}/${_pkgname_simple}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname_simple}"
+
+ if [[ ${_category_icons} = true ]]; then
+ git checkout category-icons
+ fi
+
+ python2 setup.py install --root "${pkgdir}"
+}
+
+# vim:set ts=2 sw=2 et: