summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefano Marsili2019-09-02 20:02:51 +0200
committerStefano Marsili2019-09-02 20:02:51 +0200
commita80ecc7aaf8ca2f642a502efb05df3c728bacecf (patch)
treeba04949c393c9cfa80257230034cc8c8940c9ef7
downloadaur-a80ecc7aaf8ca2f642a502efb05df3c728bacecf.tar.gz
New release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8370219ed88e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mynes
+ pkgdesc = Rolling minesweeper with islands and sonars
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://www.efanomars.com/games/mynes
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = gcc
+ makedepends = doxygen
+ makedepends = graphviz
+ makedepends = python
+ depends = stmm-games
+ depends = stmm-input
+ depends = gtkmm
+ source = git+https://gitlab.com/efanomars/mynes.git#commit=e0985980ddb214212ab3a8e1eba5cfeec29536a2
+ sha512sums = SKIP
+
+pkgname = mynes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a4986076fce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefano Marsili <efanomars@gmx.ch>
+
+pkgname=mynes
+pkgver=0.1
+pkgrel=1
+pkgdesc="Rolling minesweeper with islands and sonars"
+url='https://www.efanomars.com/games/mynes'
+arch=('x86_64')
+license=('GPL3')
+
+depends=('stmm-games' 'stmm-input' 'gtkmm')
+makedepends=('cmake' 'gcc' 'doxygen' 'graphviz' 'python')
+optdepends=()
+
+#provides=("mynes")
+#replaces=("mynes")
+#conflicts=("mynes")
+
+source=('git+https://gitlab.com/efanomars/mynes.git#commit=e0985980ddb214212ab3a8e1eba5cfeec29536a2')
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/mynes"
+
+ ./scripts/install_mynes-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --no-install --no-sudo
+}
+
+package() {
+ cd "${srcdir}/mynes"
+
+ ./scripts/priv/dd_install_mynes-all.py -b=Release -s=Off -t=Off -d=Off --installdir="/usr" --destdir="${pkgdir}" --no-configure --no-make --no-sudo
+}