summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Zhang2020-04-28 03:16:44 +1000
committerFrederick Zhang2020-04-28 03:16:44 +1000
commit4dc61821244df7af4c7555ed3e7ec6dd8d7a06bd (patch)
tree8ea1fe6cb62cba2a085eafb96cedff249e9cfa46
parent23fa1e308259bd7018ee49645338aea64e130cba (diff)
downloadaur-4dc61821244df7af4c7555ed3e7ec6dd8d7a06bd.tar.gz
build against python 3.8
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 4 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e38e6f34f08b..fdb69b4f65f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mysql-shell
pkgdesc = An interface supporting development and administration for the MySQL Server
pkgver = 8.0.20
- pkgrel = 1
+ pkgrel = 2
url = https://dev.mysql.com/downloads/shell/
arch = x86_64
arch = i686
@@ -14,7 +14,7 @@ pkgbase = mysql-shell
makedepends = rpcsvc-proto
makedepends = git
makedepends = wget
- depends = python37
+ depends = python
depends = openssl
depends = curl
source = https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-8.0.20-src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 22641eee2fc7..56a1b1d50386 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=mysql-shell
pkgver=8.0.20
-pkgrel=1
+pkgrel=2
pkgdesc='An interface supporting development and administration for the MySQL Server'
arch=('x86_64' 'i686')
url="https://dev.mysql.com/downloads/shell/"
@@ -19,14 +19,9 @@ md5sums=('14bb6e156b131889260ba0b655518579'
'1f9d75caca32d411eaaf979002253135'
'SKIP')
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
-depends=('python37' 'openssl' 'curl')
+depends=('python' 'openssl' 'curl')
makedepends=('v8-6.7-static' 'cmake' 'zip' 'zlib' 'libsasl' 'rpcsvc-proto' 'git' 'wget')
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}-src/"
- sed 's/\(FIND_PACKAGE(PythonLibs .*\) REQUIRED)/\1 EXACT REQUIRED)/' -i CMakeLists.txt
-}
-
build() {
export CC="gcc"
export CXX="g++"
@@ -45,7 +40,6 @@ build() {
-DMYSQL_SOURCE_DIR="$srcdir/mysql-$pkgver" \
-DMYSQL_BUILD_DIR="$srcdir/mysql-$pkgver/bld" \
-DHAVE_PYTHON=1 \
- -DUSE_PYTHON_VERSION=3.7 \
-DHAVE_V8=1 \
-DV8_INCLUDE_DIR="/usr/include" \
-DV8_LIB_DIR="/usr/lib" \