summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Zhang2020-04-28 01:30:02 +1000
committerFrederick Zhang2020-04-28 02:39:38 +1000
commitb1fb99bd2fe6f9a4cd74312ad7b7e99e3e0fe2ae (patch)
tree845519ed85e3cefd9c7e34643a126602807bc8cb
parent1ce23d8b8457d3d5e96edfddbe2fbcf6dc26a7a1 (diff)
downloadaur-b1fb99bd2fe6f9a4cd74312ad7b7e99e3e0fe2ae.tar.gz
update to 8.0.19; clean up
1. remove tests (until I've got time to actually validate them) 2. build with GCC 3. build against Python 3.7 [1] 4. clean up build depends [1] https://bugs.mysql.com/bug.php?id=98286
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD58
2 files changed, 31 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c266eef4cb6..727d812d2547 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,41 +1,31 @@
pkgbase = mysql-shell
pkgdesc = An interface supporting development and administration for the MySQL Server
- pkgver = 8.0.18
- pkgrel = 3
+ pkgver = 8.0.19
+ pkgrel = 1
url = https://dev.mysql.com/downloads/shell/
arch = x86_64
arch = i686
license = GPL
makedepends = v8-6.7-static
makedepends = cmake
- makedepends = clang
makedepends = zip
makedepends = zlib
makedepends = libsasl
makedepends = rpcsvc-proto
- makedepends = python2
- makedepends = python2-colorama
- makedepends = python2-pylint
- makedepends = python2-lazy-object-proxy
- makedepends = python2-singledispatch
- makedepends = python2-wrapt
- makedepends = ninja
makedepends = git
makedepends = wget
- depends = python2
+ depends = python37
depends = openssl
- noextract = googletest-release-1.8.0.zip
- source = https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-8.0.18-src.tar.gz
- source = mysql-shell-8.0.18-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-8.0.18-src.tar.gz
- source = https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-8.0.18.tar.gz
- source = mysql-boost-8.0.18.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-8.0.18.tar.gz
- source = googletest-release-1.8.0.zip::https://github.com/google/googletest/archive/release-1.8.0.zip
+ depends = curl
+ source = https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-8.0.19-src.tar.gz
+ source = mysql-shell-8.0.19-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-8.0.19-src.tar.gz&p=43
+ source = https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-8.0.19.tar.gz
+ source = mysql-boost-8.0.19.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-8.0.19.tar.gz&p=23
validpgpkeys = A4A9406876FCBD3C456770C88C718D3B5072E1F5
- md5sums = 1e04f2c53ed21a220e93f1d96e06aeda
+ md5sums = c775d0a15a7f5dd4398f7605b17c6fc5
md5sums = SKIP
- md5sums = b63e84d8ba2bbd6f82df12fc6dfb8d51
+ md5sums = 1e42b9bd431059430c7617f24608609a
md5sums = SKIP
- md5sums = adfafc8512ab65fd3cf7955ef0100ff5
pkgname = mysql-shell
diff --git a/PKGBUILD b/PKGBUILD
index a549b2214b81..9f2b74191965 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,35 @@
# Contributor: Raphaël Doursenaud <rdoursenaud@free.fr>
pkgname=mysql-shell
-pkgver=8.0.18
-pkgrel=3
+pkgver=8.0.19
+pkgrel=1
pkgdesc='An interface supporting development and administration for the MySQL Server'
arch=('x86_64' 'i686')
url="https://dev.mysql.com/downloads/shell/"
license=('GPL')
-GTEST_VERSION="1.8.0"
source=(
"https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-$pkgver-src.tar.gz"
- "mysql-shell-$pkgver-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-$pkgver-src.tar.gz"
+ "mysql-shell-$pkgver-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-$pkgver-src.tar.gz&p=43"
"https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-$pkgver.tar.gz"
- "mysql-boost-$pkgver.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-$pkgver.tar.gz"
- "googletest-release-$GTEST_VERSION.zip::https://github.com/google/googletest/archive/release-$GTEST_VERSION.zip"
-)
-noextract=("googletest-release-$GTEST_VERSION.zip")
-md5sums=(
- "1e04f2c53ed21a220e93f1d96e06aeda"
- "SKIP"
- "b63e84d8ba2bbd6f82df12fc6dfb8d51"
- "SKIP"
- "adfafc8512ab65fd3cf7955ef0100ff5"
+ "mysql-boost-$pkgver.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-$pkgver.tar.gz&p=23"
)
+md5sums=('c775d0a15a7f5dd4398f7605b17c6fc5'
+ 'SKIP'
+ '1e42b9bd431059430c7617f24608609a'
+ 'SKIP')
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
-depends=('python2' 'openssl')
-makedepends=('v8-6.7-static' 'cmake' 'clang' 'zip' 'zlib' 'libsasl' 'rpcsvc-proto' 'python2' 'python2-colorama' 'python2-pylint' 'python2-lazy-object-proxy' 'python2-singledispatch' 'python2-wrapt' 'ninja' 'git' 'wget')
+depends=('python37' 'openssl' 'curl')
+makedepends=('v8-6.7-static' 'cmake' 'zip' 'zlib' 'libsasl' 'rpcsvc-proto' 'git' 'wget')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}-src/"
+ sed 's/\(FIND_PACKAGE(PythonLibs .*\) REQUIRED)/\1 EXACT REQUIRED)/' -i CMakeLists.txt
+}
build() {
+ export CC="gcc"
+ export CXX="g++"
+
cd "$srcdir/mysql-$pkgver"
mkdir -p bld && cd $_
cmake .. -DWITH_BOOST="../boost" -DWITH_SSL=system -DWITH_PROTOBUF=bundled -Dprotobuf_BUILD_SHARED_LIBS=OFF
@@ -37,42 +39,24 @@ build() {
cd "$srcdir/$pkgname-$pkgver-src"
mkdir -p bld && cd $_
- build_tests=0
- if [[ "$MYSQL_SHELL_RUN_TESTS" ]]; then
- build_tests=1
- fi
protobuf_dir="$(basename "$(find $srcdir/mysql-$pkgver/extra/protobuf -maxdepth 1 -type d -name 'protobuf-*')")"
cmake .. \
- -DWITH_TESTS="$build_tests" \
- -DWITH_GMOCK="${srcdir}/googletest-release-$GTEST_VERSION.zip" \
- -DCMAKE_C_COMPILER=/usr/bin/clang \
- -DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
-DCMAKE_INSTALL_PREFIX=/usr \
-DMYSQL_SOURCE_DIR="$srcdir/mysql-$pkgver" \
-DMYSQL_BUILD_DIR="$srcdir/mysql-$pkgver/bld" \
-DHAVE_PYTHON=1 \
+ -DUSE_PYTHON_VERSION=3.7 \
-DHAVE_V8=1 \
-DV8_INCLUDE_DIR="/usr/include" \
-DV8_LIB_DIR="/usr/lib" \
-DWITH_SSL=system \
-DWITH_STATIC_LINKING=1 \
-DWITH_PROTOBUF="$srcdir/mysql-$pkgver/extra/protobuf/$protobuf_dir/src" \
- -DCMAKE_C_FLAGS="-I $srcdir/mysql-$pkgver/extra/protobuf/$protobuf_dir/src" \
- -DCMAKE_CXX_FLAGS="-I $srcdir/mysql-$pkgver/extra/protobuf/$protobuf_dir/src" \
- -DCMAKE_LIBRARY_PATH="$srcdir/mysql-$pkgver/bld/extra/protobuf/$protobuf_dir/cmake"
+ -DPROTOBUF_INCLUDE_DIR="$srcdir/mysql-$pkgver/extra/protobuf/$protobuf_dir/src" \
+ -DPROTOBUF_LIBRARY="$srcdir/mysql-$pkgver/bld/extra/protobuf/$protobuf_dir/cmake/libprotobuf.a"
make
}
-check() {
- # requires MySQL server, disabled by default
- if [[ "$MYSQL_SHELL_RUN_TESTS" ]]; then
- cd "$srcdir/$pkgname-$pkgver-src/bld/shell-tests"
- sed 's/python/python2/' -i mysqlx-test-run.py
- sed 's/bld"/bld\/bin"/' -i mysqlx-test-run.py
- ./mxtr
- fi
-}
-
package() {
cd "$srcdir/$pkgname-$pkgver-src/bld"
make DESTDIR="$pkgdir/" install