summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrederick Zhang2021-01-19 22:47:23 +1100
committerFrederick Zhang2021-01-19 22:47:23 +1100
commitf7c3a4da0d4ceab5e130bea95262ccc7da48a0a5 (patch)
treeaa6e7cc62f859df0fbc209d8d3ea3cbee6133fb8
parent1ff4917a0e1947d34fb869da8dad7679294d4db6 (diff)
downloadaur-f7c3a4da0d4ceab5e130bea95262ccc7da48a0a5.tar.gz
Update to 8.0.23
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD13
-rw-r--r--python3.9.patch165
3 files changed, 13 insertions, 183 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 38dc235340fa..66e6d02302a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mysql-shell
pkgdesc = An interface supporting development and administration for the MySQL Server
- pkgver = 8.0.22
- pkgrel = 2
+ pkgver = 8.0.23
+ pkgrel = 1
url = https://dev.mysql.com/downloads/shell/
arch = x86_64
arch = i686
@@ -16,17 +16,15 @@ pkgbase = mysql-shell
depends = openssl
depends = curl
optdepends = mysql-clients: login-path secret store support
- source = https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-8.0.22-src.tar.gz
- source = mysql-shell-8.0.22-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-8.0.22-src.tar.gz&p=43
- source = https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-8.0.22.tar.gz
- source = mysql-boost-8.0.22.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-8.0.22.tar.gz&p=23
- source = file://python3.9.patch
+ source = https://dev.mysql.com/get/Downloads/MySQL-Shell/mysql-shell-8.0.23-src.tar.gz
+ source = mysql-shell-8.0.23-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-8.0.23-src.tar.gz&p=43
+ source = https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-8.0.23.tar.gz
+ source = mysql-boost-8.0.23.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-8.0.23.tar.gz&p=23
validpgpkeys = A4A9406876FCBD3C456770C88C718D3B5072E1F5
- md5sums = 6408ffea4947ca052b89f94656fd6395
+ md5sums = e81f34af007178f0737339cd1d38c4d5
md5sums = SKIP
- md5sums = 2b2d93e8a3c1a29d875daf534ea87c81
+ md5sums = 27cfcf24fc754b592acd69fd32a3940a
md5sums = SKIP
- md5sums = 2a67473ad966fb3598eb6c6167aacba7
pkgname = mysql-shell
diff --git a/PKGBUILD b/PKGBUILD
index d433ef78e7d5..52d08644c2f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Raphaël Doursenaud <rdoursenaud@free.fr>
pkgname=mysql-shell
-pkgver=8.0.22
-pkgrel=2
+pkgver=8.0.23
+pkgrel=1
pkgdesc='An interface supporting development and administration for the MySQL Server'
arch=('x86_64' 'i686')
url="https://dev.mysql.com/downloads/shell/"
@@ -13,13 +13,11 @@ source=(
"mysql-shell-$pkgver-src.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-shell-$pkgver-src.tar.gz&p=43"
"https://dev.mysql.com/get/Downloads/MySQL-8.0/mysql-boost-$pkgver.tar.gz"
"mysql-boost-$pkgver.tar.gz.asc::https://dev.mysql.com/downloads/gpg/?file=mysql-boost-$pkgver.tar.gz&p=23"
- "file://python3.9.patch"
)
-md5sums=('6408ffea4947ca052b89f94656fd6395'
+md5sums=('e81f34af007178f0737339cd1d38c4d5'
'SKIP'
- '2b2d93e8a3c1a29d875daf534ea87c81'
- 'SKIP'
- '2a67473ad966fb3598eb6c6167aacba7')
+ '27cfcf24fc754b592acd69fd32a3940a'
+ 'SKIP')
validpgpkeys=('A4A9406876FCBD3C456770C88C718D3B5072E1F5')
depends=('python' 'openssl' 'curl')
optdepends=('mysql-clients: login-path secret store support')
@@ -36,7 +34,6 @@ build() {
cmake --build . --target mysqlxclient
cd "$srcdir/$pkgname-$pkgver-src"
- patch -p1 <"$srcdir/python3.9.patch"
mkdir -p bld && cd $_
protobuf_dir="$(basename "$(find $srcdir/mysql-$pkgver/extra/protobuf -maxdepth 1 -type d -name 'protobuf-*')")"
cmake .. \
diff --git a/python3.9.patch b/python3.9.patch
deleted file mode 100644
index 3f9ad9a8d9b7..000000000000
--- a/python3.9.patch
+++ /dev/null
@@ -1,165 +0,0 @@
-diff --git a/mysqlshdk/scripting/python_array_wrapper.cc b/mysqlshdk/scripting/python_array_wrapper.cc
-index 5017ccedd..481863e31 100644
---- a/mysqlshdk/scripting/python_array_wrapper.cc
-+++ b/mysqlshdk/scripting/python_array_wrapper.cc
-@@ -358,13 +358,17 @@ static PyTypeObject PyShListObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- void Python_context::init_shell_list_type() {
- if (PyType_Ready(&PyShListObjectType) < 0) {
-diff --git a/mysqlshdk/scripting/python_context.cc b/mysqlshdk/scripting/python_context.cc
-index 6ca8c5bde..3ac024056 100644
---- a/mysqlshdk/scripting/python_context.cc
-+++ b/mysqlshdk/scripting/python_context.cc
-@@ -428,9 +428,11 @@ Python_context::Python_context(bool redirect_stdio) : _types(this) {
-
- // Stores the main thread state
- _main_thread_state = PyThreadState_Get();
-
-+#if PY_VERSION_HEX < 0x03090000
- PyEval_InitThreads();
-+#endif
- PyEval_SaveThread();
-
- _types.init();
- }
-diff --git a/mysqlshdk/scripting/python_function_wrapper.cc b/mysqlshdk/scripting/python_function_wrapper.cc
-index 83e6d1a0d..aff977489 100644
---- a/mysqlshdk/scripting/python_function_wrapper.cc
-+++ b/mysqlshdk/scripting/python_function_wrapper.cc
-@@ -174,13 +174,17 @@ static PyTypeObject PyShFuncObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- void Python_context::init_shell_function_type() {
- if (PyType_Ready(&PyShFuncObjectType) < 0) {
-diff --git a/mysqlshdk/scripting/python_map_wrapper.cc b/mysqlshdk/scripting/python_map_wrapper.cc
-index acdc19569..e57fd164d 100644
---- a/mysqlshdk/scripting/python_map_wrapper.cc
-+++ b/mysqlshdk/scripting/python_map_wrapper.cc
-@@ -420,13 +420,17 @@ static PyTypeObject Key_iterator_type = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- static PyObject *dict_iter(PyShDictObject *self) {
- Key_iterator *iterator = PyObject_New(Key_iterator, &Key_iterator_type);
-@@ -545,13 +549,17 @@ static PyTypeObject PyShDictObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- void Python_context::init_shell_dict_type() {
- if (PyType_Ready(&PyShDictObjectType) < 0) {
-diff --git a/mysqlshdk/scripting/python_object_wrapper.cc b/mysqlshdk/scripting/python_object_wrapper.cc
-index 8383a689f..361e4c352 100644
---- a/mysqlshdk/scripting/python_object_wrapper.cc
-+++ b/mysqlshdk/scripting/python_object_wrapper.cc
-@@ -210,13 +210,17 @@ static PyTypeObject PyShMethodObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- static PyObject *wrap_method(const std::shared_ptr<Cpp_object_bridge> &object,
- const char *method_name) {
-@@ -641,13 +645,17 @@ static PyTypeObject PyShObjObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- static PyTypeObject PyShObjIndexedObjectType = {
- PyVarObject_HEAD_INIT(&PyType_Type, 0) // PyObject_VAR_HEAD
-@@ -733,13 +741,17 @@ static PyTypeObject PyShObjIndexedObjectType = {
- #if PY_VERSION_HEX >= 0x03040000
- ,
- 0 // tp_finalize
- #endif
--#if PY_VERSION_HEX >= 0x03080000
-+#if PY_VERSION_HEX >= 0x03080000 && PY_VERSION_HEX < 0x03090000
- ,
- 0, // tp_vectorcall
- 0 // tp_print
- #endif
-+#if PY_VERSION_HEX >= 0x03090000
-+ ,
-+ 0 // tp_vectorcall
-+#endif
- };
-
- static PyObject *object_rich_compare(PyShObjObject *self, PyObject *other,
- int op) {