summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bershatsky2017-04-08 21:54:49 +0300
committerDaniel Bershatsky2017-04-08 21:54:49 +0300
commita84c85359bec05115a30d95923ab54326cbcef50 (patch)
tree21712b34137a1d0a915c502c77f9d161fd228f67
downloadaur-a84c85359bec05115a30d95923ab54326cbcef50.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..38feb2e468e7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = mystem
+ pkgdesc = Morphological analyser of the text for Russian, Polish and English.
+ pkgver = 3.0
+ pkgrel = 1
+ epoch = 0
+ url = https://tech.yandex.ru/mystem/
+ arch = i686
+ arch = x86_64
+ license = custom
+ source_i686 = http://download.cdn.yandex.net/mystem/mystem-3.0-linux3.5-32bit.tar.gz
+ md5sums_i686 = a8f340c4f2b6868dc5e79f5433a2b827
+ source_x86_64 = http://download.cdn.yandex.net/mystem/mystem-3.0-linux3.1-64bit.tar.gz
+ md5sums_x86_64 = 79a6ecea8423b05a76829b16d2c8aca0
+
+pkgname = mystem
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1e8b9896d1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Daniel Bershatsky <bepshatsky@yandex.ru>
+pkgname=mystem
+pkgver=3.0
+pkgrel=1
+epoch=0
+pkgdesc="Morphological analyser of the text for Russian, Polish and English."
+arch=('i686' 'x86_64')
+url="https://tech.yandex.ru/mystem/"
+license=('custom')
+depends=()
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+
+source_i686=("http://download.cdn.yandex.net/mystem/mystem-$pkgver-linux3.5-32bit.tar.gz")
+source_x86_64=("http://download.cdn.yandex.net/mystem/mystem-$pkgver-linux3.1-64bit.tar.gz")
+
+md5sums_i686=('a8f340c4f2b6868dc5e79f5433a2b827')
+md5sums_x86_64=('79a6ecea8423b05a76829b16d2c8aca0')
+
+validpgpkeys=()
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ cp mystem $pkgdir/usr/bin
+}