summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMauro Santos2015-07-14 19:37:40 +0100
committerMauro Santos2015-07-14 19:37:40 +0100
commitcdc19eb098530e04730efbba501076b3d0ef426e (patch)
tree216e53f11ba2ab7b3d333eec93ec385080f0338d
downloadaur-cdc19eb098530e04730efbba501076b3d0ef426e.tar.gz
Initial import
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b20f9b6d74d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = mythes-pt_pt
+ pkgdesc = Portuguese (European) thesaurus
+ pkgver = 20060817
+ pkgrel = 2
+ url = http://openthesaurus.caixamagica.pt/
+ arch = any
+ license = GPL
+ optdepends = libmythes: offers thesaurus library functions
+ source = http://openthesaurus.caixamagica.pt/download/thes_pt_PT_v2.zip
+ md5sums = 2fa9a6845405ebb574c2f82a5cddbcbf
+
+pkgname = mythes-pt_pt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7d9165cc2ae3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Mauro Santos <registo.mailling@gmail.com>
+
+pkgname='mythes-pt_pt'
+pkgver=20060817
+pkgrel=2
+pkgdesc="Portuguese (European) thesaurus"
+arch=('any')
+url="http://openthesaurus.caixamagica.pt/"
+license=('GPL')
+optdepends=('libmythes: offers thesaurus library functions')
+source=("http://openthesaurus.caixamagica.pt/download/thes_pt_PT_v2.zip")
+md5sums=('2fa9a6845405ebb574c2f82a5cddbcbf')
+
+build() {
+ /bin/true
+}
+
+package() {
+ cd $srcdir
+ install -dm755 $pkgdir/usr/share/mythes
+ install -m644 th_pt_PT_v2.* $pkgdir/usr/share/mythes
+
+ # the symlinks
+ install -dm755 $pkgdir/usr/share/myspell/dicts
+ pushd $pkgdir/usr/share/myspell/dicts
+ for file in $pkgdir/usr/share/mythes/*; do
+ ln -sv /usr/share/mythes/$(basename $file) .
+ done
+ popd
+
+ # docs
+ install -dm755 $pkgdir/usr/share/doc/$pkgname
+ install -m644 README_th_pt_PT_v2.txt $pkgdir/usr/share/doc/$pkgname
+
+ # licences
+ install -dm755 $pkgdir/usr/share/licenses/$pkgname/
+ install -m644 README_th_pt_PT_v2.txt $pkgdir/usr/share/licenses/$pkgname
+}