summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonathan Mast2017-10-02 21:18:28 -0400
committerJonathan Mast2017-10-02 21:18:28 -0400
commitee0bddd9590c7f0311e6cfd4b44b596297652f47 (patch)
tree192d989369953944d938357c81133c95b7f2c132
downloadaur-ee0bddd9590c7f0311e6cfd4b44b596297652f47.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD40
-rw-r--r--fuse-version.patch26
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..66a51ae819cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mythfs-perl
+ pkgver = 1.36
+ pkgrel = 1
+ url = https://github.com/lstein/mythfs-perl
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-fuse
+ depends = perl-libwww
+ depends = perl-timedate
+ depends = perl-xml-simple
+ depends = perl-json
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Mythfs-perl-1.36.tar.gz
+ source = fuse-version.patch
+ md5sums = 6be14cb1821d945dddd78a4790e4615e
+ md5sums = ffef02d1818aae7d3a8b5f065e8efd16
+
+pkgname = mythfs-perl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7edd06daf120
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Jonathan Mast <jon@jonmast.com>
+pkgname=mythfs-perl
+pkgver=1.36
+pkgrel=1
+pkgdesc=''
+_dist=Mythfs-perl
+arch=('any')
+url="https://github.com/lstein/mythfs-perl"
+license=('GPL' 'PerlArtistic')
+depends=(perl-fuse perl-libwww perl-timedate perl-xml-simple perl-json)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/L/LD/LDS/$_dist-$pkgver.tar.gz" "fuse-version.patch")
+md5sums=('6be14cb1821d945dddd78a4790e4615e'
+ 'ffef02d1818aae7d3a8b5f065e8efd16')
+
+prepare() {
+ cd "$srcdir/$_dist-$pkgver"
+ patch -p1 -i "$srcdir/fuse-version.patch"
+}
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 MODULEBUILDRC=/dev/null
+ /usr/bin/perl Build.PL
+ ./Build
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ ./Build test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
+ ./Build install --installdirs=vendor --destdir="$pkgdir"
+}
diff --git a/fuse-version.patch b/fuse-version.patch
new file mode 100644
index 000000000000..d492ee31c4dc
--- /dev/null
+++ b/fuse-version.patch
@@ -0,0 +1,26 @@
+diff --git a/Build.PL b/Build.PL
+index 8a4c10f..6a7b416 100644
+--- a/Build.PL
++++ b/Build.PL
+@@ -12,7 +12,7 @@ my $build = Module::Build->new(
+ dist_author => 'Lincoln Stein <lincoln.stein@oicr.on.ca>',
+ configure_requires => { 'Module::Build' => 0 },
+ requires => {
+- 'Fuse' => '0.09',
++ 'Fuse' => '0.09.0',
+ 'LWP::UserAgent'=> '6.00',
+ 'Date::Parse' => '2.30',
+ 'XML::Simple' => '2.18',
+diff --git a/bin/mythfs.pl b/bin/mythfs.pl
+index 50d3851..ec5216e 100755
+--- a/bin/mythfs.pl
++++ b/bin/mythfs.pl
+@@ -412,7 +412,7 @@ sub check_disable_threads {
+ warn "This version of perl is not compiled for ithreads. Running with slower non-threaded version.\n";
+ return 1;
+ }
+- if ($] >= 5.014 && $Fuse::VERSION < 0.15) {
++ if ($] >= 5.014 && version->parse($Fuse::VERSION) < version->parse("0.15.0")) {
+ warn "You need Fuse version 0.15 or higher to run under this version of Perl.\n";
+ warn "Threads will be disabled. Running with slower non-threaded version.\n";
+ return 1;