summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2018-10-17 23:16:36 -0400
committerBuildTools2018-10-17 23:16:36 -0400
commitbe196d179e0a69a99f00b13ae6148e0fc86ffbbd (patch)
treed3ca2e56607f6a1ab633f2132cc5daf0870a691b
downloadaur-be196d179e0a69a99f00b13ae6148e0fc86ffbbd.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3bf47b6795c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mythhdhrrecorder-git
+ pkgdesc = MythTV External Recorder for the SiliconDust HDHR tuners
+ pkgver = r29.66c216f
+ pkgrel = 1
+ url = https://github.com/garybuhrmaster/mythhdhrrecorder
+ arch = any
+ license = Apache
+ makedepends = git
+ depends = python-requests
+ depends = python-systemd
+ provides = mythhdhrrecorder
+ conflicts = mythhdhrrecorder
+ source = git+https://github.com/garybuhrmaster/mythhdhrrecorder.git
+ sha256sums = SKIP
+
+pkgname = mythhdhrrecorder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e81b04145cee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=mythhdhrrecorder-git
+pkgver=r29.66c216f
+pkgrel=1
+pkgdesc="MythTV External Recorder for the SiliconDust HDHR tuners"
+arch=('any')
+url='https://github.com/garybuhrmaster/mythhdhrrecorder'
+license=('Apache')
+makedepends=('git')
+source=("git+https://github.com/garybuhrmaster/mythhdhrrecorder.git")
+sha256sums=('SKIP')
+depends=('python-requests' 'python-systemd')
+conflicts=('mythhdhrrecorder')
+provides=('mythhdhrrecorder')
+
+pkgver() {
+ cd "mythhdhrrecorder"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/mythhdhrrecorder"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/share/licenses/mythhdhrrecorder"
+ install -d "${pkgdir}/usr/share/doc/mythhdhrrecorder"
+ install -m755 mythhdhrrecorder "${pkgdir}/usr/bin/"
+ install -m644 LICENSE "${pkgdir}/usr/share/licenses/mythhdhrrecorder/"
+ install -m644 README.md "${pkgdir}/usr/share/doc/mythhdhrrecorder/"
+}
+
+# vim:set ts=2 sw=2 et: