summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2018-02-08 23:53:03 +0100
committerTaijian2018-02-08 23:53:03 +0100
commit06bb2e55645f7c3023084ad383bf59e037d6312a (patch)
tree9af1ae6f1bf74ec624a32322caf52f437997a1f6
parent1bb53546fab35669cdea5aa4cad6b29274ccd202 (diff)
downloadaur-06bb2e55645f7c3023084ad383bf59e037d6312a.tar.gz
fixes to re-enable all plugins
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 39 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 406db506ca11..5e5b435e05e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mythplugins
pkgver = 29.1
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = http://www.mythtv.org
arch = x86_64
@@ -22,7 +22,13 @@ pkgbase = mythplugins
makedepends = perl-xml-xpath
makedepends = python2-pillow
makedepends = python2-pycurl
+ makedepends = python2-oauth
makedepends = gdb
+ makedepends = libmariadbclient
+ makedepends = python2-lxml
+ makedepends = mysql-python
+ makedepends = urlgrabber
+ makedepends = python2-future
source = mythtv-29.1.tar.gz::https://github.com/MythTV/mythtv/archive/v29.1.tar.gz
source = mythweb-29.1.tar.gz::https://github.com/MythTV/mythweb/archive/v29.1.tar.gz
source = cdparanoia.patch
@@ -56,6 +62,11 @@ pkgname = mythplugins-mythmusic
depends = mythtv
depends = libcdio-paranoia
+pkgname = mythplugins-mythnetvision
+ pkgdesc = MythNetvision plugin for MythTV
+ depends = mythtv
+ depends = python2-oauth
+
pkgname = mythplugins-mythnews
pkgdesc = News checking plugin for MythTV
depends = mythtv
@@ -79,3 +90,9 @@ pkgname = mythplugins-mythweb
optdepends = lighttpd
optdepends = php-apache
+pkgname = mythplugins-mythzoneminder
+ pkgdesc = View CCTV footage from zoneminder in MythTV
+ install = mythplugins-mythzoneminder.install
+ depends = mythtv
+ depends = libmariadbclient
+
diff --git a/PKGBUILD b/PKGBUILD
index 2d8aeb5a7d1a..5abb753c1d77 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythgallery'
'mythplugins-mythgame'
'mythplugins-mythmusic'
-# 'mythplugins-mythnetvision'
+ 'mythplugins-mythnetvision'
'mythplugins-mythnews'
'mythplugins-mythweather'
- 'mythplugins-mythweb')
-# 'mythplugins-mythzoneminder')
+ 'mythplugins-mythweb'
+ 'mythplugins-mythzoneminder')
pkgver=29.1
-pkgrel=1
+pkgrel=2
epoch=1
arch=('x86_64')
url="http://www.mythtv.org"
@@ -22,7 +22,8 @@ license=('GPL')
makedepends=('dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'libexif' 'mesa-libgl' "mythtv=$epoch:$pkgver"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size' 'perl-cgi'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-simple' 'perl-xml-xpath'
- 'python2-pillow' 'python2-pycurl' 'gdb')
+ 'python2-pillow' 'python2-pycurl' 'python2-oauth' 'gdb' 'libmariadbclient'
+ 'python2-lxml' 'mysql-python' 'urlgrabber' 'python2-future')
source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgver.tar.gz"
"mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
'cdparanoia.patch')
@@ -91,13 +92,13 @@ package_mythplugins-mythmusic() {
make INSTALL_ROOT="$pkgdir" install
}
-#package_mythplugins-mythnetvision() {
-# pkgdesc="MythNetvision plugin for MythTV"
-# depends=('mythtv' 'python2-oauth')
-#
-# cd "$srcdir/mythtv-$pkgver/$pkgbase/mythnetvision"
-# make INSTALL_ROOT="$pkgdir" install
-#}
+package_mythplugins-mythnetvision() {
+ pkgdesc="MythNetvision plugin for MythTV"
+ depends=('mythtv' 'python2-oauth')
+
+ cd "$srcdir/mythtv-$pkgver/$pkgbase/mythnetvision"
+ make INSTALL_ROOT="$pkgdir" install
+}
package_mythplugins-mythnews() {
pkgdesc="News checking plugin for MythTV"
@@ -130,11 +131,11 @@ package_mythplugins-mythweb() {
chmod g+rw "$pkgdir/var/lib/mythtv/mythweb"/{image_cache,php_sessions}
}
-#package_mythplugins-mythzoneminder() {
-# pkgdesc="View CCTV footage from zoneminder in MythTV"
-# depends=('mythtv')
-# install='mythplugins-mythzoneminder.install'
-#
-# cd "$srcdir/mythtv-$pkgver/$pkgbase/mythzoneminder"
-# make INSTALL_ROOT="$pkgdir" install
-#}
+package_mythplugins-mythzoneminder() {
+ pkgdesc="View CCTV footage from zoneminder in MythTV"
+ depends=('mythtv' 'libmariadbclient')
+ install='mythplugins-mythzoneminder.install'
+
+ cd "$srcdir/mythtv-$pkgver/$pkgbase/mythzoneminder"
+ make INSTALL_ROOT="$pkgdir" install
+}