summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpvdp2021-04-10 12:32:54 +0000
committerpvdp2021-04-10 12:32:54 +0000
commit374a0503e4dff406313823cbe29439fd125bd1bf (patch)
treed15c188a06adfe48792dea8ecf84bb083a719eec
parent0b2d3691cd1277f0d8a0227a7629a908cca2416e (diff)
downloadaur-374a0503e4dff406313823cbe29439fd125bd1bf.tar.gz
v31+fixes so it works again with mythtv...(mythweb does not (yet) work with php8)
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD55
2 files changed, 44 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e34a8824f175..cddbbf3ad1b2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = mythplugins
- pkgver = 31.0
+ pkgver = 31+fixes.20210401.563a05b7
pkgrel = 1
- epoch = 1
+ epoch = 0
url = http://www.mythtv.org
arch = any
license = GPL
makedepends = dvdauthor
makedepends = dvd+rw-tools
makedepends = mesa-libgl
- makedepends = mythtv=1:31.0
+ makedepends = mythtv>=31+fixes.20210401.563a05b7
makedepends = perl-datetime-format-iso8601
makedepends = perl-date-manip
makedepends = perl-image-size
@@ -29,11 +29,11 @@ pkgbase = mythplugins
makedepends = perl-xml-xpath
makedepends = python-urllib3
makedepends = libcdio-paranoia
- source = mythtv-31.0.tar.gz::https://github.com/MythTV/mythtv/archive/v31.0.tar.gz
- source = mythweb-31.0.tar.gz::https://github.com/MythTV/mythweb/archive/v31.0.tar.gz
+ source = git+https://github.com/MythTV/mythweb#branch=fixes/31
+ source = git+https://github.com/MythTV/mythtv#branch=fixes/31
source = 001-mythnetvision-configure.patch
- sha256sums = 907d1747950ec6ef1ec965069c75500b4538b781333f60e16d62d519b221a86d
- sha256sums = 064a3417d2e04fc9d85355e8128ea93586fe63e17c26ba27ed758e056bd00afc
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = 08c46792e5bae7060a9362b1952caf5dc783f2ad7c609bdd61abd974499329c7
pkgname = mythplugins-mytharchive
@@ -83,7 +83,9 @@ pkgname = mythplugins-mythweb
depends = mythtv
depends = perl-cgi
optdepends = lighttpd
- optdepends = php-apache
+ optdepends = php7-apache
+ optdepends = php7-fpm
+ optdepends = nginx
pkgname = mythplugins-mythzoneminder
pkgdesc = View CCTV footage from zoneminder in MythTV
diff --git a/PKGBUILD b/PKGBUILD
index e2f253771fbd..64e21c86f005 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Taijian <taijian@posteo.de>
+# Maintainer: pvdp <pvdp@email.com>
+# Contributor: Taijian <taijian@posteo.de>
# Contributor: Jonathan Conder <jonno.conder@gmail.com>
# Contributor: Giovanni Scafora <giovanni@archlinux.org>
@@ -12,37 +13,44 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweather'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
-pkgver=31.0
+br=fixes/31
+t="${br#*/}+${br%/[0-9][0-9]}"
+pkgver=31+fixes.20210401.563a05b7
pkgrel=1
-epoch=1
+epoch=0
arch=('any')
url="http://www.mythtv.org"
license=('GPL')
-makedepends=('dvdauthor' 'dvd+rw-tools' 'mesa-libgl' "mythtv=$epoch:$pkgver"
+makedepends=('dvdauthor' 'dvd+rw-tools' 'mesa-libgl' "mythtv>=$pkgver"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size' 'perl-cgi'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-simple' 'perl-xml-xpath' 'libhdhomerun'
'python-pillow' 'python-pycurl' 'python-oauthlib' 'gdb' 'mariadb-libs' 'minizip'
'python-lxml' 'perl-xml-xpath' 'python-urllib3' 'libcdio-paranoia')
-source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgver.tar.gz"
- "mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
+source=("git+https://github.com/MythTV/mythweb#branch=$br"
+ "git+https://github.com/MythTV/mythtv#branch=$br"
'001-mythnetvision-configure.patch'
)
-sha256sums=('907d1747950ec6ef1ec965069c75500b4538b781333f60e16d62d519b221a86d'
- '064a3417d2e04fc9d85355e8128ea93586fe63e17c26ba27ed758e056bd00afc'
+sha256sums=('SKIP'
+ 'SKIP'
'08c46792e5bae7060a9362b1952caf5dc783f2ad7c609bdd61abd974499329c7')
+pkgver() {
+ cd "${srcdir}/mythtv/$pkgbase"
+ echo -n "$t.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"
+}
+
prepare() {
- cd "$srcdir/mythtv-$pkgver/$pkgbase"
+ cd "$srcdir/mythtv/$pkgbase"
patch -Np1 < "../../001-mythnetvision-configure.patch"
- cd "$srcdir/mythweb-$pkgver"
+ cd "$srcdir/mythweb"
sed -re 's@/usr/local.*/usr/share@/usr/share@' -i 'mythweb.php'
}
build() {
- cd "$srcdir/mythtv-$pkgver/$pkgbase"
+ cd "$srcdir/mythtv/$pkgbase"
./configure --prefix=/usr \
--enable-all
@@ -54,7 +62,7 @@ package_mythplugins-mytharchive() {
pkgdesc="Create DVDs or archive recorded shows in MythTV"
depends=('dvdauthor' 'dvd+rw-tools' 'mythtv' 'python-pillow')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mytharchive"
+ cd "$srcdir/mythtv/$pkgbase/mytharchive"
make INSTALL_ROOT="$pkgdir" install
}
@@ -62,7 +70,7 @@ package_mythplugins-mythbrowser() {
pkgdesc="Mini web browser for MythTV"
depends=('mythtv')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythbrowser"
+ cd "$srcdir/mythtv/$pkgbase/mythbrowser"
make INSTALL_ROOT="$pkgdir" install
}
@@ -70,7 +78,7 @@ package_mythplugins-mythgame() {
pkgdesc="Game emulator plugin for MythTV"
depends=('mythtv' 'minizip')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythgame"
+ cd "$srcdir/mythtv/$pkgbase/mythgame"
make INSTALL_ROOT="$pkgdir" install
}
@@ -78,7 +86,7 @@ package_mythplugins-mythmusic() {
pkgdesc="Music playing plugin for MythTV"
depends=('mythtv' 'libcdio-paranoia')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythmusic"
+ cd "$srcdir/mythtv/$pkgbase/mythmusic"
make INSTALL_ROOT="$pkgdir" install
}
@@ -86,7 +94,7 @@ package_mythplugins-mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
depends=('mythtv' 'python-oauthlib' 'python-urllib3')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythnetvision"
+ cd "$srcdir/mythtv/$pkgbase/mythnetvision"
make INSTALL_ROOT="$pkgdir" install
}
@@ -94,7 +102,7 @@ package_mythplugins-mythnews() {
pkgdesc="News checking plugin for MythTV"
depends=('mythtv')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythnews"
+ cd "$srcdir/mythtv/$pkgbase/mythnews"
make INSTALL_ROOT="$pkgdir" install
}
@@ -104,7 +112,7 @@ package_mythplugins-mythweather() {
'perl-xml-simple' 'perl-xml-xpath' 'perl-image-size'
'perl-datetime-format-iso8601')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythweather"
+ cd "$srcdir/mythtv/$pkgbase/mythweather"
make INSTALL_ROOT="$pkgdir" install
}
@@ -112,18 +120,23 @@ package_mythplugins-mythweb() {
pkgdesc="Web interface for the MythTV scheduler"
depends=('mythtv' 'perl-cgi')
optdepends=('lighttpd'
- 'php-apache')
+ 'php7-apache'
+ 'php7-fpm'
+ 'nginx')
+
+ sed -i 's/unix.*-fpm\.sock;/unix:\/var\/run\/php-fpm7\/php-fpm\.sock;/' "$srcdir/mythweb/mythweb.conf.nginx"
mkdir -p "$pkgdir/var/lib/mythtv/mythweb"/{image_cache,php_sessions}
- cp -R "$srcdir/mythweb-$pkgver"/* "$pkgdir/var/lib/mythtv/mythweb"
+ cp -R "$srcdir/mythweb"/* "$pkgdir/var/lib/mythtv/mythweb"
chown -R http:http "$pkgdir/var/lib/mythtv/mythweb"
chmod g+rw "$pkgdir/var/lib/mythtv/mythweb"/{image_cache,php_sessions}
+
}
package_mythplugins-mythzoneminder() {
pkgdesc="View CCTV footage from zoneminder in MythTV"
depends=('mythtv' 'mariadb-libs' 'zoneminder')
- cd "$srcdir/mythtv-$pkgver/$pkgbase/mythzoneminder"
+ cd "$srcdir/mythtv/$pkgbase/mythzoneminder"
make INSTALL_ROOT="$pkgdir" install
}