summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2020-03-17 17:39:03 +0100
committerTaijian2020-03-17 17:39:03 +0100
commitae635655b6924125a50940acc96f576ef20dd7fc (patch)
tree2befd690f8f8afce7efbefa931adc3af4240a3b9
parent7efb7498335f312df7fa923b48126499c8f034f7 (diff)
downloadaur-ae635655b6924125a50940acc96f576ef20dd7fc.tar.gz
incorporate patches to fix issue with php 7.4 in mythweb - kudos to @louis for alerting me
-rw-r--r--.SRCINFO10
-rw-r--r--003-mythweb-php7.4.patch13
-rw-r--r--004-mythweb-php7.4.patch12
-rw-r--r--PKGBUILD27
4 files changed, 46 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8041a62767bb..f8101d7366ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mythplugins
pkgver = 30.0
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = http://www.mythtv.org
arch = x86_64
@@ -23,7 +23,7 @@ pkgbase = mythplugins
makedepends = libhdhomerun
makedepends = python2-pillow
makedepends = python2-pycurl
- makedepends = python2-oauth
+ makedepends = python2-oauthlib
makedepends = gdb
makedepends = mariadb-libs
makedepends = minizip
@@ -36,10 +36,14 @@ pkgbase = mythplugins
source = mythweb-30.0.tar.gz::https://github.com/MythTV/mythweb/archive/v30.0.tar.gz
source = 001-mythwebcount.patch
source = 002-mythweb.patch
+ source = 003-mythweb-php7.4.patch
+ source = 004-mythweb-php7.4.patch
sha256sums = 7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43
sha256sums = b0569bdd6f5e6fed959d98ff883912142da42e3ee6ea3984ece116f09a5dc01c
sha256sums = 5761623dfcd36ecde723ca1b350f650c13a7d58f8107d4a88f6b0e3888df41d3
sha256sums = 86792ef1249df2b679431466312b3654f276aabb96791edf87ba41946cea67c1
+ sha256sums = 4ddb4143a2da5d7e49e9f13135d1a6bbc499acca0fe9a7765a5c412000006e7a
+ sha256sums = 4256469f5db78f8e28331a8f20576f0b917bb0d2b2d053354c4a328adfc4f0d2
pkgname = mythplugins-mytharchive
pkgdesc = Create DVDs or archive recorded shows in MythTV
@@ -71,7 +75,7 @@ pkgname = mythplugins-mythmusic
pkgname = mythplugins-mythnetvision
pkgdesc = MythNetvision plugin for MythTV
depends = mythtv
- depends = python2-oauth
+ depends = python2-oauthlib
pkgname = mythplugins-mythnews
pkgdesc = News checking plugin for MythTV
diff --git a/003-mythweb-php7.4.patch b/003-mythweb-php7.4.patch
new file mode 100644
index 000000000000..185b88add2e9
--- /dev/null
+++ b/003-mythweb-php7.4.patch
@@ -0,0 +1,13 @@
+--- a/modules/tv/includes/programs.php 2019-12-11 22:16:57.423529528 +0100
++++ b/modules/tv/includes/programs.php 2019-12-11 22:55:37.649127471 +0100
+@@ -201,6 +201,10 @@
+ }
+ // Add this program to the channel hash, etc.
+ $these_programs[] =& $program;
++
++ // Creating default object from empty value php warning
++ $channel_hash[$data['chanid']] = new stdClass();
++
+ $channel_hash[$data['chanid']]->programs[] =& $program;
+ // Cleanup
+ unset($program);
diff --git a/004-mythweb-php7.4.patch b/004-mythweb-php7.4.patch
new file mode 100644
index 000000000000..edae4a96c83c
--- /dev/null
+++ b/004-mythweb-php7.4.patch
@@ -0,0 +1,12 @@
+--- a/configure
++++ b/configure
+@@ -655,7 +655,7 @@
+ check_py_lib xml || disable_netvision "Python XML library (xml)"
+ check_py_lib urllib || disable_netvision "Python URL library (urllib)"
+ check_py_lib urllib2 || disable_netvision "Python URL library 2 (urllib2)"
+- check_py_lib oauth || disable_netvision "Python OAuth library (oauth)"
++ check_py_lib oauthlib || disable_netvision "Python OAuth library (oauth)"
+
+ disabled netvision && echo "Disabling MythNetvision due to missing dependencies."
+ fi
+
diff --git a/PKGBUILD b/PKGBUILD
index 38a8a04aff0d..7bade564056d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
pkgver=30.0
-pkgrel=4
+pkgrel=5
epoch=1
arch=('x86_64')
url="http://www.mythtv.org"
@@ -22,34 +22,35 @@ license=('GPL')
makedepends=('dvdauthor' 'dvd+rw-tools' 'ffmpeg' 'libexif' 'mesa-libgl' "mythtv=$epoch:$pkgver"
'perl-datetime-format-iso8601' 'perl-date-manip' 'perl-image-size' 'perl-cgi'
'perl-json' 'perl-libwww' 'perl-soap-lite' 'perl-xml-simple' 'perl-xml-xpath' 'libhdhomerun'
- 'python2-pillow' 'python2-pycurl' 'python2-oauth' 'gdb' 'mariadb-libs' 'minizip'
+ 'python2-pillow' 'python2-pycurl' 'python2-oauthlib' 'gdb' 'mariadb-libs' 'minizip'
'python2-lxml' 'mysql-python' 'urlgrabber' 'python2-future' 'perl-xml-xpath')
source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgver.tar.gz"
"mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
'001-mythwebcount.patch'
'002-mythweb.patch'
+ '003-mythweb-php7.4.patch'
+ '004-mythweb-php7.4.patch'
)
sha256sums=('7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43'
'b0569bdd6f5e6fed959d98ff883912142da42e3ee6ea3984ece116f09a5dc01c'
'5761623dfcd36ecde723ca1b350f650c13a7d58f8107d4a88f6b0e3888df41d3'
- '86792ef1249df2b679431466312b3654f276aabb96791edf87ba41946cea67c1')
+ '86792ef1249df2b679431466312b3654f276aabb96791edf87ba41946cea67c1'
+ '4ddb4143a2da5d7e49e9f13135d1a6bbc499acca0fe9a7765a5c412000006e7a'
+ '4256469f5db78f8e28331a8f20576f0b917bb0d2b2d053354c4a328adfc4f0d2')
prepare() {
cd "$srcdir/mythtv-$pkgver/$pkgbase"
find . -name '*.py' -type f | xargs sed -i 's@^#!.*python$@#!/usr/bin/python2@'
+
+ patch -Np1 < "../../004-mythweb-php7.4.patch"
cd "$srcdir/mythweb-$pkgver"
- local src
- for src in "${source[@]}"; do
- src="${src%%::*}"
- src="${src##*/}"
- [[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
- patch -Np1 < "../$src"
- done
-
+ patch -Np1 < "../001-mythwebcount.patch"
+ patch -Np1 < "../002-mythweb.patch"
+ patch -Np1 < "../003-mythweb-php7.4.patch"
+
sed -re 's@/usr/local.*/usr/share@/usr/share@' -i 'mythweb.php'
}
@@ -105,7 +106,7 @@ package_mythplugins-mythmusic() {
package_mythplugins-mythnetvision() {
pkgdesc="MythNetvision plugin for MythTV"
- depends=('mythtv' 'python2-oauth')
+ depends=('mythtv' 'python2-oauthlib')
cd "$srcdir/mythtv-$pkgver/$pkgbase/mythnetvision"
make INSTALL_ROOT="$pkgdir" install