summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2018-08-24 23:15:46 +0200
committerTaijian2018-08-24 23:15:46 +0200
commit94e2f2cc3a3092ed8606bef3915d3760f50c3d34 (patch)
tree5fe5778625d7b0e2c603a2bd7ccd37bf3454f74a
parent16b734acb4281bbab251f94697c1f33f9f3fe4fb (diff)
downloadaur-94e2f2cc3a3092ed8606bef3915d3760f50c3d34.tar.gz
incorporate changes due to removal of libx264, add new patch file
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--libx264.patch25
3 files changed, 40 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c68cebba241..f8374fd8ece0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mythtv
pkgdesc = A Homebrew PVR project
pkgver = 29.1
- pkgrel = 9
+ pkgrel = 10
epoch = 1
url = https://www.mythtv.org/
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = mythtv
makedepends = libmariadbclient
makedepends = libxml2
makedepends = libcec
- makedepends = x264
makedepends = libcdio
makedepends = lirc
makedepends = perl-io-socket-inet6
@@ -31,7 +30,7 @@ pkgbase = mythtv
depends = urlgrabber
depends = qt5-webkit
depends = x265
- depends = libx264
+ depends = x264
depends = jack
depends = libvpx
depends = libvdpau
@@ -57,11 +56,13 @@ pkgbase = mythtv
source = 99-mythbackend.rules
source = sysusers.d
source = freetype2.patch
+ source = libx264.patch
sha256sums = e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e
sha256sums = ed5ca54de26b7cd8a64e09626eed6e09f35d677daf88c530bb24cc4252bcce6d
sha256sums = ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333
sha256sums = 470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae
sha256sums = 4451cbb28513e03cc2f62c50581daeb436d027f8a0968ba5d99a3b05da103343
+ sha256sums = 810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344
pkgname = mythtv
diff --git a/PKGBUILD b/PKGBUILD
index 75db45613ad8..fa589a6e2515 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,15 +7,15 @@
pkgname=mythtv
pkgver=29.1
-pkgrel=9
+pkgrel=10
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
url="https://www.mythtv.org/"
license=('GPL')
depends=('libass' 'qt5-script' 'libavc1394' 'fftw' 'exiv2' 'taglib' 'libva' 'libiec61883' 'perl-net-upnp' 'urlgrabber'
- 'qt5-webkit' 'x265' 'libx264' 'jack' 'libvpx' 'libvdpau' 'lame' 'libxinerama' 'libpulse' 'libxrandr' 'mysql-python')
-makedepends=('git' 'help2man' 'yasm' 'libmariadbclient' 'libxml2' 'libcec' 'x264' 'libcdio' 'lirc' 'perl-io-socket-inet6' 'perl-libwww'
+ 'qt5-webkit' 'x265' 'x264' 'jack' 'libvpx' 'libvdpau' 'lame' 'libxinerama' 'libpulse' 'libxrandr' 'mysql-python')
+makedepends=('git' 'help2man' 'yasm' 'libmariadbclient' 'libxml2' 'libcec' 'libcdio' 'lirc' 'perl-io-socket-inet6' 'perl-libwww'
'perl-dbd-mysql' 'python2-lxml')
optdepends=('glew: for GPU commercial flagging'
'libcec: for consumer electronics control capabilities'
@@ -31,12 +31,14 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$p
'mythbackend.service'
'99-mythbackend.rules'
'sysusers.d'
- 'freetype2.patch')
+ 'freetype2.patch'
+ 'libx264.patch')
sha256sums=('e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e'
'ed5ca54de26b7cd8a64e09626eed6e09f35d677daf88c530bb24cc4252bcce6d'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
- '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
- '4451cbb28513e03cc2f62c50581daeb436d027f8a0968ba5d99a3b05da103343')
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
+ '4451cbb28513e03cc2f62c50581daeb436d027f8a0968ba5d99a3b05da103343'
+ '810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344')
prepare() {
cd $pkgname-$pkgver/$pkgname
@@ -45,6 +47,9 @@ prepare() {
#apply freetype2.patch to fix configure error
patch -Np1 -i ../../freetype2.patch
+
+ #apply libx264.patch
+ patch -Np1 -i ../../libx264.patch
}
build() {
diff --git a/libx264.patch b/libx264.patch
new file mode 100644
index 000000000000..8401b2f9c26e
--- /dev/null
+++ b/libx264.patch
@@ -0,0 +1,25 @@
+--- a/external/FFmpeg/libavcodec/libx264.c
++++ b/external/FFmpeg/libavcodec/libx264.c
+@@ -279,7 +279,7 @@
+
+ x264_picture_init( &x4->pic );
+ x4->pic.img.i_csp = x4->params.i_csp;
+- if (x264_bit_depth > 8)
++ if (X264_BIT_DEPTH > 8)
+ x4->pic.img.i_csp |= X264_CSP_HIGH_DEPTH;
+ x4->pic.img.i_plane = avfmt2_num_planes(ctx->pix_fmt);
+
+@@ -889,11 +889,11 @@
+
+ static av_cold void X264_init_static(AVCodec *codec)
+ {
+- if (x264_bit_depth == 8)
++ if (X264_BIT_DEPTH == 8)
+ codec->pix_fmts = pix_fmts_8bit;
+- else if (x264_bit_depth == 9)
++ else if (X264_BIT_DEPTH == 9)
+ codec->pix_fmts = pix_fmts_9bit;
+- else if (x264_bit_depth == 10)
++ else if (X264_BIT_DEPTH == 10)
+ codec->pix_fmts = pix_fmts_10bit;
+ }