summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2020-06-11 00:19:37 +0200
committerTaijian2020-06-11 00:19:37 +0200
commitd5c414900c92b24243ddf7c5f47737f647905cba (patch)
treefcc0e4a58e7cfe3654cdeb23b549cf825c2cac06
parent9e14a930627fbb49980783db378009a76f5e089a (diff)
downloadaur-d5c414900c92b24243ddf7c5f47737f647905cba.tar.gz
add patch by bigcajun826 to fix issues with the Qt 5.15 update
-rw-r--r--.SRCINFO6
-rw-r--r--001-mythpainter.patch10
-rw-r--r--PKGBUILD8
3 files changed, 19 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5e737c282274..cb903847a4c0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mythtv
pkgdesc = A Homebrew PVR project
pkgver = 31.0
- pkgrel = 2
+ pkgrel = 3
epoch = 1
url = https://www.mythtv.org/
arch = any
@@ -41,7 +41,7 @@ pkgbase = mythtv
optdepends = mariadb-clients: Database-Frontend for client deployment
optdepends = python-requests: for metadata-lookup / cover art
optdepends = python-requests-cache: for metadata-lookup / cover art
- optdepends = xmltv>0.6.1: for Schedule Direct TV listings
+ optdepends = xmltv: for Schedule Direct TV listings
conflicts = myththemes
conflicts = mythplugins-mythvideo
replaces = myththemes
@@ -50,10 +50,12 @@ pkgbase = mythtv
source = mythbackend.service
source = 99-mythbackend.rules
source = sysusers.d
+ source = 001-mythpainter.patch
sha256sums = 907d1747950ec6ef1ec965069c75500b4538b781333f60e16d62d519b221a86d
sha256sums = 086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3
sha256sums = ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333
sha256sums = 470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae
+ sha256sums = fcb078842ecceb636183ed358fb4acfb25ddbe456b2529763519a6661a29baec
pkgname = mythtv
diff --git a/001-mythpainter.patch b/001-mythpainter.patch
new file mode 100644
index 000000000000..7a046bee5f40
--- /dev/null
+++ b/001-mythpainter.patch
@@ -0,0 +1,10 @@
+--- a/libs/libmythui/mythpainter.cpp
++++ b/libs/libmythui/mythpainter.cpp
+@@ -5,6 +5,7 @@
+ // QT headers
+ #include <QRect>
+ #include <QPainter>
++#include <QPainterPath>
+
+ // libmythbase headers
+ #include "mythlogging.h"
diff --git a/PKGBUILD b/PKGBUILD
index b4e6300d34cc..de206ca90cdc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mythtv
pkgver=31.0
-pkgrel=2
+pkgrel=3
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('any')
@@ -24,18 +24,20 @@ optdepends=('glew: for GPU commercial flagging'
'mariadb-clients: Database-Frontend for client deployment'
'python-requests: for metadata-lookup / cover art'
'python-requests-cache: for metadata-lookup / cover art'
- 'xmltv>0.6.1: for Schedule Direct TV listings')
+ 'xmltv: for Schedule Direct TV listings')
conflicts=('myththemes' 'mythplugins-mythvideo')
replaces=('myththemes' 'mythplugins-mythvideo')
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
'mythbackend.service'
'99-mythbackend.rules'
'sysusers.d'
+ '001-mythpainter.patch'
)
sha256sums=('907d1747950ec6ef1ec965069c75500b4538b781333f60e16d62d519b221a86d'
'086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
- '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
+ 'fcb078842ecceb636183ed358fb4acfb25ddbe456b2529763519a6661a29baec')
prepare() {
cd $pkgname-$pkgver/$pkgname