summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Bunton2020-04-14 01:39:41 +1000
committerJames Bunton2020-04-14 09:05:28 +1000
commit985d4caa6712d9876fe98e3672ec9c063ab0b385 (patch)
tree43cb4806ac75b7c67f53e053bda848152d09ba73
parent11c3c9ff577c4ce2c5c3eeb0bdb1235d5aedbcd5 (diff)
downloadaur-985d4caa6712d9876fe98e3672ec9c063ab0b385.tar.gz
Properly hide mouse cursor on Wayland
-rw-r--r--PKGBUILD7
-rw-r--r--wayland-hide-mouse-cursor.patch20
2 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3db0bc2d169a..3981e84923be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -83,6 +83,7 @@ source=(
'mythbackend.service'
'mythtv.desktop'
'mythtv.png'
+ 'wayland-hide-mouse-cursor.patch'
'99-mythbackend.rules'
'sysusers.d'
)
@@ -91,6 +92,7 @@ sha256sums=(
'7e6b4cb48bb76dca1c991aebab2790d09f2ba87519ed5f90597e3b5d13a9cd76'
'3fd2018d0d5aaa7d530835305dac80d4ca7d8fc991cdf9e1cebadebd86e25c03'
'12cb52bf9b084a4f16419c9370fef0450ce6a11308b0c3f7240f4f83df7e2ab6'
+ 'bc43d38acac43bbc15dd6b27b74ff5a7e7abc16ad80ce6e676b108a2d501660c'
'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
'470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae'
)
@@ -100,6 +102,11 @@ pkgver() {
echo -n "31+fixes.$(git show -s --format=%cd --date=short | tr -d -).$(git rev-parse --short=8 HEAD)"
}
+prepare() {
+ cd "${srcdir}/mythtv/mythtv"
+ patch -Np2 < "${srcdir}/wayland-hide-mouse-cursor.patch"
+}
+
build() {
cd "${srcdir}/mythtv/mythtv"
diff --git a/wayland-hide-mouse-cursor.patch b/wayland-hide-mouse-cursor.patch
new file mode 100644
index 000000000000..f7f84caf1eda
--- /dev/null
+++ b/wayland-hide-mouse-cursor.patch
@@ -0,0 +1,20 @@
+diff --git a/mythtv/libs/libmythui/mythmainwindow.cpp b/mythtv/libs/libmythui/mythmainwindow.cpp
+index 7bdfe41bb3..d111162286 100644
+--- a/mythtv/libs/libmythui/mythmainwindow.cpp
++++ b/mythtv/libs/libmythui/mythmainwindow.cpp
+@@ -1002,16 +1002,10 @@ void MythMainWindow::Init(bool mayReInit)
+
+ // On Compiz/Unit, when the window is fullscreen and frameless changing
+ // screen position ends up stuck. Adding a border temporarily prevents this
+ setWindowFlags(windowFlags() & ~Qt::FramelessWindowHint);
+
+- if (!inwindow)
+- {
+- LOG(VB_GENERAL, LOG_INFO, "Using Frameless Window");
+- flags |= Qt::FramelessWindowHint;
+- }
+-
+ // Workaround Qt/Windows playback bug?
+ #ifdef _WIN32
+ flags |= Qt::MSWindowsOwnDC;
+ #endif