summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNick Boughton2019-12-06 12:19:34 +0000
committerNick Boughton2019-12-06 12:19:34 +0000
commit7a891c4dc738eff6bd211012dcea3bc14bd4955b (patch)
tree3d80aa794ef18f5e7708d6d57cbe22703f475f42
parent0e942408b6c93dccd4836c2be60f07406ebf9a25 (diff)
downloadaur-7a891c4dc738eff6bd211012dcea3bc14bd4955b.tar.gz
updated for upstream version
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 11cd6518b68b..cd4bcb1edc63 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = swnt
pkgdesc = Command line GM tools for Stars Without Number
- pkgver = 0.7.5
+ pkgver = 0.8.1
pkgrel = 1
url = https://github.com/nboughton/swnt
arch = x86_64
license = MIT
- makedepends = go
- depends = git
optdepends = hugo: export sectors as hugo sites
- source = swnt-0.7.5.tar.gz::https://github.com/nboughton/swnt/archive/v0.7.5.tar.gz
- sha1sums = 714325463242a3eb981ecb69ea3a859a6926b63f
+ source = swnt-0.8.1.tar.gz::https://github.com/nboughton/swnt/releases/download/v0.8.1/swnt.tar.gz
+ sha1sums = d4c7564783bce5725f42f40f8ca8191e6a113610
pkgname = swnt
diff --git a/PKGBUILD b/PKGBUILD
index 0f855e5ec20d..95e7b50b08db 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,21 @@
# Maintainer: N.Boughton, <nicholasboughton@gmail.com>
pkgname=swnt
-pkgver=0.7.5
+pkgver=0.8.1
pkgrel=1
pkgdesc="Command line GM tools for Stars Without Number"
arch=('x86_64')
url="https://github.com/nboughton/swnt"
license=("MIT")
-depends=("git")
-makedepends=('go')
optdepends=('hugo: export sectors as hugo sites')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/archive/v${pkgver}.tar.gz")
-sha1sums=('714325463242a3eb981ecb69ea3a859a6926b63f')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/nboughton/swnt/releases/download/v${pkgver}/${pkgname}.tar.gz")
+sha1sums=('d4c7564783bce5725f42f40f8ca8191e6a113610')
-build() {
- cd "$srcdir/$pkgname-$pkgver"
- go build -v -o swnt
-}
+#build() {
+# cd "$srcdir/$pkgname-$pkgver"
+# go build -v -o swnt
+#}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ cd "$srcdir/build/"
+ install -Dm755 "${pkgname}.linux" "${pkgdir}/usr/bin/${pkgname}"
}