summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Herrmann2017-03-03 14:10:54 +0100
committerDavid Herrmann2017-03-03 14:10:54 +0100
commitbe7e97d66e1bc3848a9a3740d9d422a7e9162289 (patch)
treee1f53a2f52a46e1c33f8b90a7508a352375fa161
parent56a590e6e32d4aa3b58671b6683f05e79cc3e7d5 (diff)
downloadaur-be7e97d66e1bc3848a9a3740d9d422a7e9162289.tar.gz
n-acd-git: enable tests
Enable the tests, now that meson was updated in the official packages. Also do some minor tweaks to keep it in sync with other c-util pkg-builds. Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
-rw-r--r--PKGBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4a828f0f3262..d80044a5ccad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ makedepends=('git' 'meson')
provides=("$_pkgname")
conflicts=("$_pkgname")
source=("$pkgname::git+https://github.com/$_pkgorg/$_pkgname")
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
@@ -26,13 +26,11 @@ pkgver() {
build() {
rm -Rf "build"
meson --prefix=/usr --buildtype=release "$pkgname" "build"
- ninja -C "build"
+ ninja -v -C "build"
}
check() {
- # XXX: Skipping tests is only supported with meson-0.37
- # ninja -v -C "build" test
- :
+ ninja -v -C "build" test
}
package() {